Jump to content

API (error Authentication Failed)


Recommended Posts

I've been trying to access WHMCS using the External API.


I've seen a few threads on the forum regarding this, and as far as I can see I'm doing everything right. But if someone can point out what I may be missing I'd be grateful.


My PHP (from the WHMCS example) is as follows:


/* *** WHMCS XML API Sample Code *** */

$url = "https://mydomain.com/includes/api.php"; # URL to WHMCS API file goes here
$username = "adminusername"; # Admin username goes here
$password = "adminpassword"; # Admin password goes here

$postfields = array();
$postfields["username"] = $username;
$postfields["password"] = md5( $password );
$postfields["accesskey"] = "random_string"; <-- Have tried both with and without an access key.
$postfields["action"] = "getproducts";
$postfields["pid"] = "2";
$postfields["responsetype"] = "xml";

$query_string = "";
foreach ($postfields AS $k=>$v) $query_string .= "$k=".urlencode($v)."&";

$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_POST, 1);
curl_setopt($ch, CURLOPT_TIMEOUT, 30);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $query_string);
curl_setopt($ch, CURLOPT_SSL_VERIFYHOST, 0);
curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);
$xml = curl_exec($ch);
if (curl_error($ch) || !$xml) $xml = '<whmcsapi><result>error</result>'.
'<message>Connection Error</message><curlerror>'.
curl_errno($ch).' - '.curl_error($ch).'</curlerror></whmcsapi>';

$arr = whmcsapi_xml_parser($xml); # Parse XML

print_r($arr); # Output XML Response as Array

Debug Output - Uncomment if needed to troubleshoot problems
echo "<textarea rows=50 cols=100>Request: ".print_r($postfields,true);
echo "\nResponse: ".htmlentities($xml)."\n\nArray: ".print_r($arr,true);
echo "</textarea>";

function whmcsapi_xml_parser($rawxml) {
	$xml_parser = xml_parser_create();
	xml_parse_into_struct($xml_parser, $rawxml, $vals, $index);
	$params = array();
	$level = array();
	$alreadyused = array();
	foreach ($vals as $xml_elem) {
	  if ($xml_elem['type'] == 'open') {
		 if (in_array($xml_elem['tag'],$alreadyused)) {
		 	$xml_elem['tag'] = $xml_elem['tag'].$x;
		 $level[$xml_elem['level']] = $xml_elem['tag'];
		 $alreadyused[] = $xml_elem['tag'];
	  if ($xml_elem['type'] == 'complete') {
	   $start_level = 1;
	   $php_stmt = '$params';
	   while($start_level < $xml_elem['level']) {
		 $php_stmt .= '[$level['.$start_level.']]';
	   $php_stmt .= '[$xml_elem[\'tag\']] = $xml_elem[\'value\'];';



I've ensured that my IP is listed in the API IP Access Restriction section of the Security tab in General Settings.


And I've also double checked that my admin user has API access set in the Administrator Roles settings.


I've tried accessing the API via the access key method as well, but this didn't wok either.


So I cannot think of anything else that may causing the `error Authentication Failed` error.


Checking the Admin & Activity Logs show nothing, plus I've also checked the webserver error logs, but no joy.


Anyone got any ideas on what I'm missing, or where I can find a log of what error is happening?

Edited by elijahpaul
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated