Jump to content
Blasgo

Customer Invoice Mail

Recommended Posts

Good morning community

How do I make all the services to be renewed appear on the "Customer Invoice"?
In all "Customer Invoice" emails I only see that the hosting service appears and does not add the domain, both services were purchased the same day.
The domain renewal is sent in different mail.

I will greatly appreciate your help

Greetings.

captura-whmcs.png

Share this post


Link to post
Share on other sites
20 hours ago, Blasgo said:

How do I make all the services to be renewed appear on the "Customer Invoice"?
In all "Customer Invoice" emails I only see that the hosting service appears and does not add the domain, both services were purchased the same day.
The domain renewal is sent in different mail.

do you have "Separate Invoices" enabled either for this client, or for a client group that this client might be assigned to ?

https://help.whmcs.com/m/payments/l/761423-creating-separate-renewal-invoices-for-a-client-s-services

Share this post


Link to post
Share on other sites

Hello, I have reviewed and "Separate Invoices" is not enabled. What will be happening? When notifications arrive, my clients think that the payment is only from Hosting.

captura-whmcs.png

Share this post


Link to post
Share on other sites
7 minutes ago, Blasgo said:

What will be happening? When notifications arrive, my clients think that the payment is only from Hosting.

do both the domain and service/product have the same next due date? it's generating 2 separate invoices ??

Share this post


Link to post
Share on other sites

If they have the same expiration date, they do not generate 2 invoices, in the only invoice only the payment of the Hosting and the domain appears in another email and you have to see it in the client's area. 😐

captura-whmcs.png

Share this post


Link to post
Share on other sites
23 hours ago, Blasgo said:

If they have the same expiration date, they do not generate 2 invoices, in the only invoice only the payment of the Hosting and the domain appears in another email and you have to see it in the client's area. 

that sounds like expected behaviour, e.g if domain & hosting both have the same next due dates, 1 October, then they'll be on the same invoice (unless separating invoicing is enabled); if the next due dates are different, e.g 1 Oct & 2 Oct, then that would generate too invoices/emails.

so to ensure that both hosting and domain are on the same invoice, they must have the same next due date.

Share this post


Link to post
Share on other sites
1 hour ago, brian! said:

so to ensure that both hosting and domain are on the same invoice, they must have the same next due date.

If they have the same dates.
How can I solve it? again I send an invoice for September 20 with the price of the hosting and has not included the domain. 😪

Share this post


Link to post
Share on other sites

are you manually sending the invoice from the admin area client summary page ?

Share this post


Link to post
Share on other sites
On 9/8/2019 at 10:53 AM, brian! said:

are you manually sending the invoice from the admin area client summary page ?

no, everything is automatic.

Share this post


Link to post
Share on other sites

@Blasgo Check under automation settings then domain reminder. if any of these have a number other than 0 then it will do the domain renewal earlier to give the client more time to renew. 

 

To stop this simply set all to 0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Tengri
      Hello!
      For some reasons sometimes our banks don't accept invoice from customers without stamp, name of CEO and signature. Is there any way that when the user chooses payment via a Bank under the invoice had the name of the Director signature and stamp.
      Thank you!
    • By sokalsondha
      Hello community...
      I came back again. Can someone help me with my system.
      What happened is..
      We sell yearly service. Let's say client bought service 01/04/2018
      And his next due date is 31/03/2019.
      Now system generate invoice on 15/03/209
       
      But he didn't paid.
      He decide to pay on may..
      I knw the service will be suspended. But it's not a problem.
      Now if he pay on may .. I see his next due date will be 31/03/2020 not 01/05/2020
       
      So he is loosing a month when he didn't used the service in April.
      Can we have a hook to update the next invoice date the customer paid+365 days? 
      Please help me
       
    • By eliasaphram
      Im trying to use Githubs version of AutoAuth:
      https://github.com/JonTheWong/whmcs-autoauth-invoice
      I've followed the steps in the description, but are getting wrong login credentials error. Below you can see the different steps and the code that i have;
      To install this script you need to place all files in your root directory of WHMCS
      example: /home/user/public_html/domain/whmcs/
      Generate a hash and enter it in configuration.php above the last ?>
      $autoauthkey = "REPLACE-WITH-SYSTEM-KEY";
      Also include it into the script.
      You can generate a hash using; openssl rand -hex 32 on linux.
      Then add this value to the top of your email template;
      {assign var='hash' value=$client_email|cat:"REPLACE-THIS-PART-WITH-SECRET-KEY"}
      Then add this link anywhere in your email template.
      Login Auth: {$whmcs_url}lauth.php?email={$client_email}&zmkey={$hash|md5}
      Invoice Auth: {$whmcs_url}iauth.php?email={$client_email}&invoice={$invoice_num}&zmkey={$hash|md5}
      Quote Auth: {$whmcs_url}qauth.php?email={$client_email}&quote={$quote_number}&zmkey={$zmkey|md5}
      Notes
      Quick not for version 7+
      Due to security settings, you have to modify configuration.php and add the following code to the bottom, above the last ?>
      $smarty_security_policy = array( 'mail' => array( 'php_modifiers' => array( 'md5', 'time', 'sha1', 'urlencode', 'header', ), ), );  
      In the config file:
      $hash = "302BEA0FDBC6ADB8F8A25919318B532D";
      $autoauthkey = "Correct_password";
      $smarty_security_policy = array(
          'mail' => array(
              'php_modifiers' => array(
                  'md5',
                  'time',
                  'sha1',
                  'urlencode',
                  'header',
              ),
          ),
      );
      ?>
       
      In the iauth file:
       
      <?php
      /*
      Created by JonTheWong @ Zenith Media Canada - www.zenithmedia.ca
      Visit our public repo - https://github.com/JonTheWong/whmcs-autoauth-invoice
      */
      $whmcsurl = "https://www.webbsnacks.se/whmcs/dologin.php"; /* replace with your url */
      $autoauthkey = "Correct_password"; /* same as in configuration.php */
      $secretkey = "A_new_key_generated"; /* generate a new key for this script */
      if (md5($_GET['email'].$secretkey) != $_GET['zmkey'])
      die('Något fel har skett, vänligen kontakta oss på info@webbsnacks.se för att gå vidare.');
      $email = $_GET['email'];
      $timestamp = time();
      $hash = sha1($email.$timestamp.$autoauthkey);
      $goto = "viewinvoice.php?id=".$_GET['invoice'];
      $url = $whmcsurl."?email=$email&timestamp=$timestamp&hash=$hash&goto=".urlencode($goto);
      header("Location: $url");
      exit;
      ?>
       
       
      Do anyone know what the issue might be? Since im not getting the "die" text, there should be nothing wrong with the hash, correct?
    • By ovi
      I'm using WHMCS 7.7.1 & WordPress.
      I have integrate WordPress with WHMCS using whmcs-bridge.
      Problem is, a client register for hosting and domain & complete the payment for the invoice but after his payment the invoice still showing unpaid.
      Note that: After payment client redirecting to client area this one working fine. Only invoice showing unpaid
      Please help me to solve it 
    • By Shivansh
      Hi Community,
      Anyone help me regard this when our client is the visit our invoice in our website prohosty.com then Rupees Symbol is working Fine See this screenshot http://prntscr.com/myl1j4 and 
      if client download invoices then rupees symbols change into "?" symbol see this screenshot http://prntscr.com/myl1r8
      Please help to fix it
  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated