Jump to content

Parmeter missing username

Recommended Posts

I've been searching for hours and can't find an answer to this specific problem:


I tried registering a domain through the front end of the system, (for a different organization than my web biz, so a "real" registration).

The module queue shows that the original registration with Reseller Club failed because of missing field 'state'.

I found the answer to that problem and updated the client profile with the Province. All fields in the client profile are completed.


When I press "Retry" the process fails with the error message:

"Required parameter missing: username"

The module debugging reports gives the following:

Under "Request":




[auth-userid] => ******

[api-key] => ********************************

[username] =>

[passwd] => xxxxxxxx

[name] =>

[company] => N/A

[address-line-1] =>

[address-line-2] =>

[city] =>

[state] =>

[zipcode] =>

[country] =>

[phone-cc] => 0

[phone] =>

[lang-pref] => en

[posteddata] => auth-userid=******&api-key=********************************&&passwd=xxxxxxxxxx&name=%20&company=N%2FA&address-line-1=0&address-line-2=0&&&&&phone-cc=0&phone=&lang-pref=en



Under "Response":



[status] => ERROR

[message] => Required parameter missing: username



It seems as though the module is sending almost no registration information, and the response is halting the process on the first error (first empty field, "username")


Is this a bug? Or is it me!?


Appreciate any help.



Share this post

Link to post
Share on other sites

for resellerclub, username usually refers to the email address - so that's where the issue might lay.

Share this post

Link to post
Share on other sites

Thanks for replies. Using the latest version of WHMCS - 7.2.3.

All fields in the client profile are completed. Email address was in the first time I tried to run the domain registration, which the module is supposed to submit to Reseller Club as the user name.

What was originally missing was the "State" (missing parameter: state"). I added that to the profile and clicked try again in the module queue. This time username was the missing parameter, but in fact if you look at the submission array, no user details at all are included. Or am I reading it wrong?



Share this post

Link to post
Share on other sites

Hi Andrew


I'm not sure I understand the question exactly - do you mean if I just try to register a domain using the domain registration form in the client area?

If so, that's how I started, and it didn't work because there was a missing field in the profile ("state" = Province in Canada). After I corrected that I think I only have the module queue to work with for that particular domain. I can see if the whole process can be deleted, issue a credit to the client records and try again from scratch.

To me there's still a problem. Although there was an error on the first attempt to register, wouldn't a well written script check for missing fields, request the information from the user and then carry on with the process? I'm not a coder at all, so I hope that's not coming across as arrogant! Just seems there should be a logical correction step so that the process doesn't fail completely.

Also, does the posted error log message I included earlier give any clues about what is going wrong?


I'll try a registration from scratch again and see if it works.


Appreciate the help.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Web Host Pro
      I just checked OnlineNIC out and there prices are great and look very professional.
      Anyone have an experience with them?
      Do they like to take domains that expire right away or have any major issues at all?
    • By Web Host Pro
      I have two registers I'm using now, the older one I just want to keep for renewals for accounts that used them already.
      The new one I want to use for all new registers and renewal for customers that use the new one.
      Where can disable the old register so it's not option for new registration?
      Is there a way to choose a default register or disable the old one for new registration?
      Old is ENOM and the new is OnlineNIC
  • Recently Browsing   0 members

    No registered users viewing this page.


Important Information

By using this site, you agree to our Terms of Use & Guidelines