Jump to content
dandju

Domains page shows max 10 domains on child themes

Recommended Posts

Hello,

I was wondering if anyone has the same issue with the domains page within the client area (/clientarea.php?action=domains) (WHMCS 8.1 GA)?

The customer can only see a maximum of 10 domains. He has 19 active domains in total (which I can see in the admin panel), and when navigating to "/clientarea.php?action=domaindetails&id=<DOMAIN_ID>" I can see the details of the missing domain when entering the ID of the domain manually.

I have then debugged the Smarty template of this page and could see:

$domains

Origin: "Smarty object"

Value

Array (10)

So for some reason only 10 domains are provided to Smarty/template? Is it a bug? Or should the datatable load the next few domains when clicking next (but next button is disabled)? And datatables says: Showing 1 to 10 of 10 entries.

Thanks for the help and happy new year!

 

Share this post


Link to post
Share on other sites
5 minutes ago, dandju said:

The customer can only see a maximum of 10 domains.

is the template not showing the pagination at the bottom of the table ??

ZoIdKUL.png

Share this post


Link to post
Share on other sites

Hi Brian,

8 minutes ago, brian! said:

is the template not showing the pagination at the bottom of the table ??

No, just the 10 domains and this first page (even when setting it to show 50):

Oh - and it even says 19 in the filter at the left side.

image.thumb.png.88fd4181028ca48345002777a72d4e9d.png

Edited by dandju

Share this post


Link to post
Share on other sites

i'm not seeing that locally....

WVAkAO7.png

pagination and filtering is working...

i'm testing on a v8.1b1 dev, and I assume the GA release hasn't broken this... does it work with other languages ??

Share this post


Link to post
Share on other sites
10 minutes ago, brian! said:

does it work with other languages ??

Just tested with another client and language, still the same:

image.png.691dc1bab128c08d79e0253fe5c18c19.png

Also disabled all hooks just to ensure its not related, but still the same.

As I do not know how it is intended to work, it might be an issue with the WHMCS core? As it only provides 10 domains within the $domains variable?

Btw. do you see all those domains in the source code (or in the $domains variable)?

Edited by dandju

Share this post


Link to post
Share on other sites
4 minutes ago, dandju said:

As I do not know how it is intended to work, it might be an issue with the WHMCS core? As it only provides 10 domains within the $domains variable?

a debug window for me is showing all 32 domains in the $domains array - what happens if you use the Six theme instead ??

Share this post


Link to post
Share on other sites
40 minutes ago, brian! said:

what happens if you use the Six theme instead

Good idea! And indeed, it shows all correctly in the six template?!

I have now noticed that this is related to the child theme - when selecting the "Twenty-One" theme directly, it shows all domains correctly, but when selecting the child theme (which is using the twenty-one as the main template), the domains page shows only 10.

Just for further testing I have removed all files from the child theme folder and just left the theme.yamlfile with the following content:

# Custom Theme Configuration File
name: "Custom Theme"
author: "DD"
config:
   parent: twenty-one

When selecting the "Custom Theme" within the General Settings in WHMCS, the domains page only shows 10 domains?

Share this post


Link to post
Share on other sites

Hello @dandju

Thank you for your report, although I havent seen this issue reported anywhere else I will see if I can replicate this and open a case if needed, I'll let you know in this thread once I have completed testing,

Share this post


Link to post
Share on other sites
16 hours ago, dandju said:

Update: Also applies to other data tables (eg. invoices, tickets) ... when using the child theme.

now that you mention that it's a child theme, I can see it on all the tables too.

AkusMXd.png

add it to your bug list @xyzulu 🙄

Share this post


Link to post
Share on other sites
13 minutes ago, WHMCS Marcus said:

We are pleased to announce we have released a Hotfix for this issue: 

@WHMCS Marcus - small point, but isn't the tag on the hotfix post wrong, it says 8.0_HF, but surely there should be a v8.1 folder of hotfixes (to follow the existing pattern for 8.0, 7.10, 7.9 etc releases) and this hotfix should be in there rather than with the older v8.0 hotfixes and then this tagged 8.1_HF?

Share this post


Link to post
Share on other sites

Thank you @WHMCS Marcus for the quick update. I can confirm that the workaround has resolved the issue (could not test the patch yet) 👍 

And thank you very much @brian! for the continuous assistance that helped me to narrow down the issue.

Thank you again both of you and a happy new year!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By WHMCS Marcus
      An issue has been identified in the 8.1.0 release - published on 29th December 2020, that when utilizing a Child Theme, the pagination property is not inherited from the parent. This can result in partial loading or missing items from various sections in the Client Area:
    • By xyzulu
      Seeing as WHMCS don't have a list of the bugs they have had reported and are working on, I thought I'd create this thread to track the current 8.1 GA bugs. If you find any, please let me know and I will edit this post to add them (hopefully I have enough permission to do so). Below is the list of ones I am aware of:
      CORE-16022 double validation warning password reset page: https://whmcs.community/topic/304324-twenty-one-template-minor-tweaks/?do=findComment&comment=1346483 CORE-16025 twenty one theme hard coded strings: Twenty one theme hard-coded string - WHMCS 8.1 Beta Discussion Board - WHMCS.Community CORE-16026  client email history missing: https://whmcs.community/topic/304324-twenty-one-template-minor-tweaks/?do=findComment&comment=1346510 (this might be a showstopper for you)  
       
       
      PS WHMCS staff you are welcome to edit this post of mine to add any other bugs currently being worked on if you like.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated