Jump to content
wintech2003

Stripe Statement Descriptor "Shopping Cart"

Recommended Posts

I upgraded to 7.8.3 which is supposed to fix #MODULE-7114 however, descriptors have not been fixed as far as I can see.

This is how it should look like:
1010969852_Screenshot2019-09-29at15_55_43.thumb.png.3a48357a50857a44928313dc73918254.png

And this is how it looks like now (the 7.8.3 update was applied on Sep 25th):

1882898810_Screenshot2019-09-29at15_59_29.thumb.png.97b4c7870d1b9a0d6f7b2bbc58160437.png

Only payments charged via the daily cron at 9:00AM appear correct. Payments done by the customers themselves don't show the invoice number and the statement descriptor shows up twice:

850317140_Screenshot2019-09-29at16_32_08.png.fca47ba30cff8a618cc24e94655d9414.png

Share this post


Link to post
Share on other sites

Yes we are also seeing this with 7.8.3.  The description in Stripe is still not correct.

It now shows our {Descriptor} + Shopping Cart for manual Stripe payments.

But between the 7.8 and 7.8.3 release it was showing {Descriptor}  + invoice number.  I can see a transaction on our account on Sept 24th that is set this way.  For all cron payments it shows {Business Name} + Tax Invoice #99999  (Tax Invoice is a language string we use).

The description needs to be consistent!  Include the Descriptor or Business Name and the invoice reference number.

stripe-payments.jpg

Share this post


Link to post
Share on other sites

We've got another bug opened with WHMCS (MODULE-7151) regarding this issue.

In our situation, some manual payments are correctly using our custom description string.  In other cases, a manual payments is sent as "CompanyName Shopping Cart" instead.  We don't enable automated cron payments (yet), all our invoices are paid manually and there doesn't seem to be any pattern it as far as I can see...

Share this post


Link to post
Share on other sites

Hi there,

We have opened case MODULE-7151 regarding the statement descriptor for initial signups being displayed as "Shopping Cart".

This is because there is no invoice on order when the payment with Stripe is being made, so an invoice number cannot be sent.

Share this post


Link to post
Share on other sites

Hello,

I'm not sure this is limited to initial signups (we haven't had any signups recently so I can not confirm), for us, it's happening for manual payments from existing customers. Customers that used to have a correct statement descriptor before 7.8 when they paid manually. 

If an existing customer pays his (monthly/recurring) invoice (for an already active service, not a new order) before the due date, manually, through the Client Area by clicking the "Pay Now" button on the invoice, then his statement descriptor will be wrong. If the same customer chose to leave the invoice to auto-pay via cron on the due date, the statement descriptor would be correct.

Share this post


Link to post
Share on other sites
On 10/6/2019 at 10:16 PM, WHMCS John said:

This is because there is no invoice on order when the payment with Stripe is being made, so an invoice number cannot be sent.

In my example screenshot the ‘Shopping Cart’ entry is for a domain renewal so an invoice number did exist. 

So MODULE-7151 needs to be expanded beyond initial signups. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated