Jump to content

Domain Checker Captcha Bug for Multiple Consecutive Searches?


Recommended Posts

Hello all,


Just been doing some testing and came across what seems to be a bug when searching for a domain.


With the Default Captcha enabled I searched for a test domain from /domainchecker.php. After completing the Captcha and hitting 'Check Availability' it worked normally, so it showed the result of my search, however I then entered a different domain to search, entered the new 5 character verification code and again hit 'Check Availability'....this failed...it came up with the error 'The characters you entered didn't match the image shown. Please try again.'


I completed the exact same test a number of times, all with the same result....it only allows one time search for the domain. As soon as one search is completed even though it does change the Captcha code one has to refresh the page and enter the code for a successful search.


Can someone else confirm this?



Link to comment
Share on other sites

I can't seem to reproduce this - on our own whmcs or on yours... I could get that error message by doing a search, getting a result and then refreshing the page... but that makes sense as the captcha would have changed, so i'd be resending the wrong code...


i'm just wondering if this could be a browser issue at your end - have you tried using another browser?

Link to comment
Share on other sites

I changed it to the Google reCaptcha option as that works, so I am guessing that's what you tried. The issue is with the 5 character code option. That fails for some reason when entering a second domain search without refreshing the paid or at least getting one error. I have put it back to the failing one for the time being as I am troubleshooting it today.


EDIT - Forgot to say, yes tested with multiple browsers and PC/Mac :?:

Edited by CCSupport
Link to comment
Share on other sites

Very weird. Might have to grab a support ticket for this one. I have retested a few times with the 5 character code one and no matter what I try it always fails on the second submission of a domain search. It does change the code after the initial search but doesn't accept it.

Link to comment
Share on other sites

hmm... your site is now starting to show this error for me too... :?:


I would be tempted to do two things...


1. clear your templates_c cache.

2. disable the enom pro name spinner addon for now... what i'm seeing is that initial searches work, but if I try to search after the enom pro addon displays the alternative domain suggestions - that's when I see the error message... it then shows the domainchecker page as normal with just pricing tables and no enom options... if I do a search again at that point it will work, but as the results will display the enom name suggestions, the next search will fail... and so on.


however, domainchecker.php?search=bulk seems to work fine... this doesn't seem to use the enom Pro addon.


I don't use enom, and i'm not familiar with the Pro addon - but if it helps, Chrome is stating "Uncaught SyntaxError: Unexpected token," at line 27 in domainchecker.php - which probably means there might be an error in domainchecker.tpl, header.tpl or some other template file.


you should take a look at the whmcs demo - http://demo.whmcs.com/domainchecker.php - do you see the same thing occuring there, or does it work as normal? the demo seems fine to me.

Edited by brian!
Link to comment
Share on other sites

Thanks Brian.


I will remove the {namespinner} code and see if it changes anything. I think you are spot on though. It's certainly down to either my Theme or eNom Pro coding in some way as if I change my theme to 'Default' it works perfectly.


Will let you know when I have removed the namespinner to see what happens.


We are going to be having a full front-end overhaul of the site next month bringing it to HTML5 coding but it this is back-end then it's going cause confusion with issues! Best get it sorted before then :-P

Link to comment
Share on other sites

A gentleman and scholar you are Brian....namespinner is the culprit! Works perfectly fine after removing the {namespinner} code in the domainchecker.tpl file.


I will create a support ticket with the vendor to see what we can do.


Thanks again for the advice, very much appreciated as always.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated