Jump to content

Store? Phplive?

Recommended Posts

Here's a fun one. 
Set up a plain dev install, just to see what I'd need to do to upgrade. Did not enable the Marketplace, did not install any additional apps/plugins/addons.
Added a single fake client, gave him just a single domain name (real one of mine). Log into his account, see the dreaded red padlock on the domain. Clicking on it, it tries to take me to /store. WHMCS generates a "wrong page" error, since I'd assume that's where it would go if you enabled the marketplace. 
The docs say it would instead take me to cart.php, but it doesn't. Have to assume it's because I don't have an SSL provisioning partner activated...which would be the same condition in the actual install being upgraded.

Adding to that, the "page not found" page says I should "click below to contact support"...with nothing below to click on. Intrigued, I view the source, only to find this (mydomain has been edited):


It loads that into an invisible div. 
What's most interesting about it is not only have I never bought, installed or accessed phplive on this domain (much less in this dev install), but it's looking for it on the main doc root, not within the dev install.

I contacted WHMCS support, and received less than satisfactory results. Rather than explain why either condition might be happening, I was asked for admin access to "look into it".
Anyone who doesn't have marketplace activated, and no SSL provisioning set up, you might want to check your installs for this.

Link to comment
Share on other sites

No templates, it's a plain install from a direct download. This was in twenty-one template.
Besides, this is something being generated by WHMCS, when it comes across something it can't show, like /store when marketplace isn't active. It's also looking for it in the root directory, and non-https (https set up in the dev settings as https...domain.com/dev/).

Link to comment
Share on other sites

After a pile of digging, it's all on me, and WHMCS is innocent. The affected domain was a business takeover from long ago, and there was an artifact from back when I took it over that never once showed it's face (nothing went missing until WHMCS wasn't working properly). Found it, fixed it, I'll go hide now. 

Link to comment
Share on other sites

Ever look at a list of files in a directory and totally miss one?
I'd looked for (and in) specific things like .htaccess files, apache  config, you name it. 
What I missed, every time I looked at the file structure was a file named 404.shtml. Been so long since I used something like that I just blanked over it, and it never dawned on me to see what was in it. 
One of the *last* things tried, since I'd wrongly assumed WHMCS was causing it (it was, after all, only happening within the updated WHMCs install at the time), was grepping the directory for part of the line. Oops. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated