Jump to content
Sign in to follow this  

[SOLVED] Two Factor Authentication No Longer Works?

Recommended Posts

I've been using two factor authentication (2FA) with time-based tokens for WHMCS with the Symantec VIP Access App for quite a while, but today when I attempted to log in to update WHMCS from v. 8.0 to 8.1, my code was rejected and I had to use the backup code.

I went into the admin to reset 2FA for my account, and my App immediately recognizes the QR code, but WHMCS gives me the "The code you entered did not match what was expected. Please re-scan or enter the code and try again."

I've tried several times, but no luck. The App still works fine with the other sites I use it with.  Is this a bug with WHMCS?

Edited by linux4me

Share this post

Link to post
Share on other sites

I figured this out thanks to this article. I actually did look at the documentation, but I didn't find this page.

It turns out the problem was my phone. It's set to get the time automatically from Verizon, but it was three minutes slow! I manually set the time in the phone and was able to get 2FA working in WHMCS.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By pikerr
      Dear All,
      Is it possible to enable 2FA authentication for selected clients only whom always raise payment dispute due to fraud?
      Any advise?
      Thank you
    • By Web Host Pro
      We have a customer  that is worried about the the WHMCS auto login bypassing the cpPanel 2FA.  Is there a way to enable 2fa when using the WHMCS auto login from WHMCS to cPanel?
    • By wsa
      Here is a screenshot of my new module

    • By loopmail
      Looking around and some clients have enabled 2fa for the primary user, but there seem to be no details for it on the contacts page. is this not a feature on offer to contacts or a way for administrators to see the status/clear the status for contacts?

    • By davet
      This was working previously but I was alerted by a customer that it is no longer working. I tried to set it up on a test customer but when I try to add 2FA using Google Authenticator it returns the following:
      The code you entered did not match what was expected.
      I tried to close google Authenticator... re-opened it and tried again but still no luck.
      I do have a paid license for the Time Based 2FA
      Anyone else having this issue? Any ideas how to get this working again?
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated