Jump to content
ROQ

Apple email sending problem

Recommended Posts

Hi guys,

I have email setup via smtp and I'm having problems with any Apple email address (@me.com @icloud.com etc) where every email send from the WHMCS system is being rejected by the apple servers.  But if I sent an email manually from my own email client to the same addresses they are going through ok and don't bounce back.

Is there anything I can do to get these system emails sent through ok?

Share this post


Link to post
Share on other sites

Hi @ROQ

Please note that there are multiple reasons why your emails may be sent to a spam folder or rejected, most relating to server configuration. WHMCS Email templates in themselves should not trigger any standard spam rules currently.

As all IP addresses have been recycled or reused, it is possible that at some point in time your mail server IP address may have had a bad reputation, or if your mail server is in a shared hosting environment(or similar to one) other users mail habits can affect your reputation as well.

Here are a few guidelines to help with this issue:

1.Check your mail servers IP to verify it is not listed in any black lists at https://mxtoolbox.com/blacklists.aspx

2.Contact your web hosting or mail server provider for investigation into your IP reputation. They will be able to contact other email providers on your behalf.

3.Verify your domain has an accurate and strict SPF record setup, as well as a correct PTR record.

 

Share this post


Link to post
Share on other sites

Thanks for the reply, I don't think there is an issue with my mail servers because if I send an email manually to an apple address from the same address I have configured in whmcs, it gets sent without issue. 

Share this post


Link to post
Share on other sites

if you are getting a rejection / bounce back message, what exactly does it say? 

Share this post


Link to post
Share on other sites

So this is what I get back:

 

Reporting-MTA: dns; smtp.livemail.co.uk
X-Postfix-Queue-ID: C467B280172
X-Postfix-Sender: rfc822; my email address
Arrival-Date: Wed, 17 Apr 2019 09:00:32 +0100 (BST)

Final-Recipient: rfc822; customer@me.com
Original-Recipient: rfc822;customer@me.com
Action: failed
Status: 5.7.1
Remote-MTA: dns; mx4.mail.icloud.com
Diagnostic-Code: smtp; 550 5.7.1 [CS01] Message rejected due to local policy.
    Please visit https://support.apple.com/en-us/HT204137
 

Share this post


Link to post
Share on other sites

As sending via the mail client on the same SMTP works it isn't likely an issue with SPF or DKIM but would suggest to double check those just in case.  Also, double check that WHMCS is set to SMTP and not php mail.  And lastly, have you tried to contact them via the email they list on that page? 

Share this post


Link to post
Share on other sites
On 4/10/2019 at 6:06 AM, ROQ said:

if I sent an email manually from my own email client to the same addresses they are going through ok

Is that email client also sending from the same server/domain WHMCS is installed on?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated