Jump to content

cPanel packages fetch not working

Recommended Posts


I have created two Hosting packages in WHM.

Then I have  added a cpanel server  following the instructions read here https://docs.whmcs.com/CPanel/WHM and from Product/Services > Server the test connection is working fine and I'm able to login to WHM starting from WHMCS.

As you can see in the attachments, the problem happens when I try to create a New Product.  In the Module Settings, if I select cPanel as "Module Name" and the Server group contianing the server I added, I don't fetch any packages in the "WHM package name" even if i click to re-fetch values.

I'm using WHMCS 7.5 and WHM is on CloudLinux 7.5 v68.0.39 on A2Hosting provider. 


Please can you help me ?





Link to comment
Share on other sites

Thank you @ChrisD

I have done what you suggest. In attachment what I show in the log section after I have tried to reload the list. The result seems to be empty.

Thank you in advance if you can suggest me what I can do.





Debug Log.PNG

Link to comment
Share on other sites

  • WHMCS Support Manager

Hi @proxup,

Thanks for providing that information. This behaviour suggests two things:

1. There are no packages configured under the WHM user whose details are entered on the WHMCS Setup > Products/Services>  Servers page

2. This indicates an invalid character in the listpkgs response from the cPanel API. You can examine the cPanel API result if you send the request to the API:


  • Replace https://hostname.domain.tld with your server hostname
  • Replace cpsess3250785970 with the corresponding cpsess that shows up from your login to WHM
Link to comment
Share on other sites

  • 1 year later...
On 6/22/2018 at 6:48 PM, proxup said:

Thank you John.

I have solved. The issue was on WHM side. The packages were exeeding the limits of the Hosting plan.

Hello, I have the same problem. Can you please explain what the problem was?

Edited by krokos
Link to comment
Share on other sites

9 hours ago, krokos said:

Hello, I have the same problem. Can you please explain what the problem was?

Please go into Utilities > Logs > Module Logs the Enable the module log, once done, please back to module settings, load the list and then head back to your module log to check for errors in the logs.

Link to comment
Share on other sites

  • 2 months later...
On 21/6/2018 at 12:18, WHMCS John said:

Hola @proxup ,

Gracias por proporcionar esa información. Este comportamiento sugiere dos cosas:

1. No hay paquetes configurados bajo el usuario WHM cuyos detalles se ingresan en la página Configuración WHMCS> Productos / Servicios> Servidores

2. Esto indica un carácter no válido en la respuesta listpkgs de la API de cPanel. Puede examinar el resultado de la API de cPanel si envía la solicitud a la API:

 https: //hostname.domain.tld: 2087 / cpsess3250785970 / json-api / listpkgs

  • Reemplace  https: //hostname.domain.tld con el nombre de host de su servidor
  • Replace cpsess3250785970 con el cpsess correspondiente que se muestra desde su inicio de sesión en WHM

I have the same problem: I did everything indicated there and this comes out:


please help!

Link to comment
Share on other sites

  • 4 months later...
On 10/7/2019 at 5:42 AM, snake said:

I contacted my host and they fixed it. It was obviously a firewall issue.



On 11/3/2013 at 3:20 AM, imaticon said:



You have to pass at least 2 valid name servers when register a domain. As a resellerclub reseller, you have 4 partially or fully branded nameservers. Pass these name servers by default for any register/transfer.


If you haven't set up your branded name servers and want do so, you may interested in the following post: http://www.resellerclub-mods.com/en/community/15-resellerclub-lounge-english/217-reseller-and-starting-with-whmcs-part-1.html





Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated