Jump to content

Recommended Posts

Hello,

My website has ssl, however you need to manually type https in order to use it. I changed the General Settings in the admin, i changed domain, to have https, and system url, to https also. Now when I go to the site, it doesnt work.  I attached a screenshot of what I see when I go to my site.

Screenshot from 2020-11-17 20-32-57.png

Share this post


Link to post
Share on other sites

Sounds like you have a redirect else where that is trying to force https but isn't checking that https is used. 

Edited by steven99

Share this post


Link to post
Share on other sites

You need to check the .htaccess file for rewrites that send to https, control panel settings that force ssl, etc - though those are usually safe.

Share this post


Link to post
Share on other sites

Well if you can't get in to the admin because of that redirection loop, then you need to change the database via phpmyadmin -> tblconfig (or tblconfiguration or something like) table -> system url option.    Did you check .htaccess and other parts as suggested first though? 

Share this post


Link to post
Share on other sites

How do I edit the system url option. I have php my admin. I clicked on the database, then the table, but how do I edit it?

Share this post


Link to post
Share on other sites

Nevermind, I fixed it. But now I have another problem. In the admin panel, it keeps signing me out over and over. How do i fix this?

Share this post


Link to post
Share on other sites

You will want to make sure you're accessing https vs http when logging in and that the system url matches the one you're using. 

Share this post


Link to post
Share on other sites

How do I change the system URL to https. When i login to the admin panel, I get signed out immediately  

Share this post


Link to post
Share on other sites

Are you accessing the admin via https:// and it redirects you to http://?  if so, that would be why it logs you out as the session cookie wont match .  As such, you need to edit the database directly and change the option there.   or use http:// and change the password afterwards -- not the best solution but it will get you there. 

Share this post


Link to post
Share on other sites

That worked, but now I have another issue where I randomly get redirected to the hompage of the whmcs admin panel randomly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated