Jump to content
Jbro

I must have lost a lot of money because of this shortcoming or bug what so ever you call it

Recommended Posts

Posted (edited)

Today after years of using whmcs I found out that there were times I simply give people free service and hosting for years in a few ocations

I am not sure but a few months ago it might have happened with 500 dollars invoice too.

 

This is the sotry

 

A customer orders a hosting or adds fund  but for some reason payment is not processed  from paypal to my whmcs it could be because some thing was wrong with my

server  for example mod security or firewall  what so ever so customer does not get confirmation and I do not receive any payment confirmation from paypal as well

customer complains that he has paid but did his invoice has not been marked paid ,  I check my paypal account and I indeed see that he has made payment and money is there

so I think to myself it might be a delay and eventually it will come through I wait for  a few hours more but when this does not happen I manually mark the invoice paid

after a day or two the payment from paypal comes in and the payment goes as credit to customer because I had already marked the invoice paid.

 

Now after years of doing this  ( not sure not often but I am sure i did this a few times and one might be a big invoice )

Now I know I should have never marked those invoiced paid or at least I should have double checked those accounts

 

 

So What now?  I feel I am a looser 😞

Edited by Jbro

Share this post


Link to post
Share on other sites
23 minutes ago, Jbro said:

Now I know I should have never marked those invoiced paid or at least I should have double checked those accounts

personally, I wouldn't call it a bug - if you manually mark an invoice as paid, but then PayPal later tells WHMCS that it's received the payment, I would expect what happened as normal behaviour...

26 minutes ago, Jbro said:

So What now?  I feel I am a loser 😞

first step might be to run the Credits Reviewer Report and see when credits have been added to the accounts.

Share this post


Link to post
Share on other sites

How are you marking them paid?  Are you doing an "Add payment" via the invoice page or using the "Mark paid" button in the invoice list?   From what you have described, I would say you are using the Marked paid button .  If you use the add payment and enter the transaction ID from paypal, WHMCS should not then record that transaction when they send the confirmation to WHMCS as it will see there is already a transaction with that ID. 

Also, the delay could be if they are using echeck as WHMCS wont record the payment until that clears. 

Share this post


Link to post
Share on other sites
2 hours ago, steven99 said:

How are you marking them paid?  Are you doing an "Add payment" via the invoice page or using the "Mark paid" button in the invoice list?   From what you have described, I would say you are using the Marked paid button .  If you use the add payment and enter the transaction ID from paypal, WHMCS should not then record that transaction when they send the confirmation to WHMCS as it will see there is already a transaction with that ID.

So simple and I did not notice that all those years !   😞  Thank you very much

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated