Jump to content
Codge

friendly urls redirect to homepage / 7.4.3 -> 7.6.1

Recommended Posts

Hello!

I've recently upgraded our whmcs server to 7.6.1 with a new template and home page but I'm experiencing an issue since the upgrade. 

I've tested this to confirm it's not the template by switching to six template and experience the same issue. 

 

- When selecting knowledgebase.php url, it will go the knowledgebase domain, but when clicking an article it will redirect you back to the home page but the url will be the knowledgebase url (https://xxxxxxxxxx.com/index.php?rp=/knowledgebase/2/App-Running-Slow.html)

I've checked htaccess and didn't notice any changes within it and can post if required. I do however remember having friendly urls set to 'Full Friendly Rewrite' in 4.3 that is now not highlighted green in the settings pane. For that matter none of them are highlighted green, even basic URLs? I've attached an image to illustrate the selections. 

I will turn off Mode Override to see what the system detected selection is, but will remain ON regardless if turning it off? 

 

 

Capture.JPG

1.JPG

Share this post


Link to post
Share on other sites
On 07/11/2018 at 14:37, Codge said:

I've tested this to confirm it's not the template by switching to six template and experience the same issue. 

going forward, i'd recommend doing all testing with Six rather than a custom template.,,, and then only when it working on there, try it in a custom template. thanks.png

On 07/11/2018 at 14:37, Codge said:

When selecting knowledgebase.php url, it will go the knowledgebase domain, but when clicking an article it will redirect you back to the home page but the url will be the knowledgebase url (https://xxxxxxxxxx.com/index.php?rp=/knowledgebase/2/App-Running-Slow.html)

are they private articles - e.g does the user need to be logged in to view the article ???

IqM97A5.png

you should be able to view either article by passing the article ID in the url, e.g knowledgebase.php?action=displayarticle&id=1 - but using Six on your site, redirects me to the login page... which implies that they are both marked as private.

On 07/11/2018 at 14:37, Codge said:

I will turn off Mode Override to see what the system detected selection is, but will remain ON regardless if turning it off? 

I think that's a bug as i've seen it occur locally in my v7.6 dev too - it changes on-screen, but doesn't update the database... I can disable it directly in the database, but you shouldn't need to even try that yet at this stage.

if the articles are currently marked as private, can you make one of the kb article public (e.g untick the private box) and see if that article redirects correctly afterwards.

Share this post


Link to post
Share on other sites

Leaving on template six till we get this fixed 🙂

7 minutes ago, brian! said:

are they private articles - e.g does the user need to be logged in to view the article ???

They are private articles, will make them public and test again.

- I've made them public, but still redirects back to homepage via the link at the knowledgebase. Directly going to the URL displays it properly. eg. knowledgebase.php?action=displayarticle&id=1 

It just seems to not like the basic url setting of https://xxxxxxxxxx.com/index.php?rp=/knowledgebase/2/App-Running-Slow.html

Share this post


Link to post
Share on other sites
On 11/7/2018 at 11:37 AM, Codge said:

Hello!

I've recently upgraded our whmcs server to 7.6.1 with a new template and home page but I'm experiencing an issue since the upgrade. 

I've tested this to confirm it's not the template by switching to six template and experience the same issue. 

 

- When selecting knowledgebase.php url, it will go the knowledgebase domain, but when clicking an article it will redirect you back to the home page but the url will be the knowledgebase url (https://xxxxxxxxxx.com/index.php?rp=/knowledgebase/2/App-Running-Slow.html)

I've checked htaccess and didn't notice any changes within it and can post if required. I do however remember having friendly urls set to 'Full Friendly Rewrite' in 4.3 that is now not highlighted green in the settings pane. For that matter none of them are highlighted green, even basic URLs? I've attached an image to illustrate the selections. 

I will turn off Mode Override to see what the system detected selection is, but will remain ON regardless if turning it off? 

 

 

Capture.JPG

1.JPG

What you experience is normal for WHMCS developers. 😵

WHMCS does not use the .htaccess rules anymore or template URL's like it did in the past, at least it does not respect Apache rules anymore. They use some internal PHP Laravel routing now which is encoded in the files and you cannot change the behavior. And yes, its broken !!!

At least it does not work in most servers that have other custom rules in place. I complained tons of times about SEO url's being broken now. If you have your web server working in a specific way, or have other .htacess rules in your domain that are causing issues with WHMCS, I'm afraid there is nothing you can't do except install WHMCS on a different server. WHMCS is not compatible with other .htaccess rules, other web servers or even anything else that tries to rewrite urls, because as I said, you cannot change the routing it does internally, its encoded on PHP files, and if you happen to have other software that changed something in your web server that also affects WHMCS, you are literally without a choice to fix this.

Try to search in your FAQ articles, or other POST forms, it not just the link you mentioned for domains but many other things are probably not working on your installation at this point.

Share this post


Link to post
Share on other sites
16 hours ago, yggdrasil said:

it not just the link you mentioned for domains but many other things are probably not working on your installation at this point.

A lot is currently messed up. Just wanted to get the knowledgebase sorted first. The whole admin panel won't change to monthly or yearly graphs, or refresh with our paypal accounts. 

Would it be best to a clean install on another VPS? We don't have any redirects or edits to htaccess besides the standard setup. If it would be best to do a clean install, would it be advisable to revert back to an older version? 

Share this post


Link to post
Share on other sites
21 hours ago, Codge said:

A lot is currently messed up. Just wanted to get the knowledgebase sorted first. The whole admin panel won't change to monthly or yearly graphs, or refresh with our paypal accounts. 

Would it be best to a clean install on another VPS? We don't have any redirects or edits to htaccess besides the standard setup. If it would be best to do a clean install, would it be advisable to revert back to an older version? 

Did you open a support ticket already?

Edited by yggdrasil

Share this post


Link to post
Share on other sites
41 minutes ago, yggdrasil said:

Did you open a support ticket already?

Yes, and damn ioncube... 

Share this post


Link to post
Share on other sites
On 10/11/2018 at 15:42, Codge said:

A lot is currently messed up. Just wanted to get the knowledgebase sorted first. The whole admin panel won't change to monthly or yearly graphs, or refresh with our paypal accounts.  

that sounds like an incomplete/corrupted installation... at the very least, you're looking at reuploading the /vendor and /include folders again and hoping that fixes all your issues.

also, get these things working on Six/SC before using a custom template - otherwise, you won't know whether it's a WHMCS issue or a template issue and it will take longer to figure out which.

21 hours ago, yggdrasil said:

Would it be best to a clean install on another VPS? We don't have any redirects or edits to htaccess besides the standard setup. If it would be best to do a clean install, would it be advisable to revert back to an older version?

if you've updated the database to the latest version, I don't think you can revert it back... unless you had a backup copy of the database from the previous version... but then you will lose the data between then and now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines