Jump to content

Help! Uncaught ReferenceError: initStripe is not defined


Recommended Posts

Using WHMCS version 8.3.2  Twentyone theme + Standard Cart, so in other words, no mods.  I also tried changing theme to Six and the Cart to Modern

Payments have been working fine.  - then a customer went to pay invoice at "Billing > My Invoices > Pay Now (basically it's the checkout) - with CC via Stripe and got  "Remote Transaction Failure. Please Contact Support".  They contacted me to report the error.

In the transaction log, it simply shows 

Status => error
message => An unexpected error - No Stripe Payment Method found from token
token => 

In DevTools, loading ""Billing > My Invoices > Pay Now"  it shows "Uncaught ReferenceError: initStripe is not defined" - so it appears it's not seeing the stripe js file? ?

Things I've tried: 

Nothing seems to be working....  Help !

Screenshot from devtools:



initstripe is not defined-screenshot.jpg

Edited by sol2010
Link to comment
Share on other sites

Oh no, card processing issues are back for the 12th time this year  😝

It does actually look different to the last time whmcs broke card processing and I'm not brave enough to use the latest beta on a production site! 

Does it show in stripe as a failed payment? It may have more insight into what was missing - sometimes the logs aren't great but stripe captures attempts and gives better feedback! A duplicate js element  can cause as many problems as a missing element when it comes to billing- although undoubtedly we'll never fully know what's been changed just that it was a highly requested feature that nobody claims 🤣


I'm not sure it'll even make it to stripe under these circumstances but certainly worth a go just to see if there's anything! Undoubtedly you raised a ticket with whmcs and they acted shocked and directed you here? 

Link to comment
Share on other sites

OK Problem solved - it was the TAWK live chat addon causing a conflict.

In typical fashion, I had removed all addons - but had not removed that one as it was from the WHMCS store.... gone now!

Fair dues to support team who answered my ticket swiftly and pointed out the issue.



Edited by sol2010
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated