Jump to content

Short form fields in quotes


Recommended Posts

Something that's been bugging me that I haven't been able to find when doing a quote. Each of the lines for items in the quote are being limited to 28 pixels tall, cutting off the bottom of the item name a bit. This is in the admin area, when creating a quote. 

Inspecting the element shows the CSS is inline and not in the CSS files, even my custom one. Looking through the templates doesn't find it either. 
To add to the weirdness, the empty line at the bottom for the next item you want to add? Much taller. It's not until you add content that it shrinks to 28px and cuts off the words.
Any idea what I've missed here? It has to be somewhere...



Edited by bear
Link to comment
Share on other sites

  • WHMCS Staff

Hi @bear,

That's certainly strange! As a test, can you try (or have you tried?) replacing your current "admin" directory with a fresh copy from a new install ZIP at https://download.whmcs.com

This will confirm for sure if the issue lies in your template edits or not.

If that resolves it, you can start re-applying any changes you had made until it happens again.

If it doesn't, let me know which browser you're using and I'll see if I can reproduce any issue. If I can, I'll provide a resolution here.

Link to comment
Share on other sites

Happens in Waterfox and Firefox, latest on both. 
As for console errors, there's a metric ton of moz window and things of that nature, all generated by all.min.css. None appear related to this particular issue, and as mentioned, this is seemingly caused by inlined CSS, not from a style sheet. If I have to guess, something within the encrypted files is potentially behind it, since it does not exist anywhere within readable files.

Link to comment
Share on other sites

Tried a third browser, Vivaldi, and it doesn't do it nearly as much. 
This is the field code:

<textarea name="desc[49]" class="expanding form-control" style="overflow: hidden;display: block;height: 28px;">Design - Starter Design Package - 10 page</textarea>

The "style" is being added in at the page level, not from a style sheet.  If I go into the browser web tools and disable the 28px height, it looks normal. If I enable the height:auto declaration in textarea.formcontrol , it grows to like 34px. Disable, it shrinks down to the proper height. 
This is clearly being added outside of external styles, at the page level display. Be really appreciated if that practice went away. 😞

Link to comment
Share on other sites

Found a workaround, and it doesn't appear to break anything else. There's padding settings in the CSS that will affect this. Add this into your custom.css in the admin folder, and it will override the default padding of 6px top and bottom. That fixes it. 

	padding: 4px 12px!important;


Link to comment
Share on other sites

22 minutes ago, brian! said:

only direct license users will be able to download that file

If they have a current support period, which I do not. 😞

The css override I posted fixes it, and doesn't appear to blow anything else up. 

Edited by bear
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated