Jump to content
jburns

Email Piping - Failed to make mounts private: Permission denied

Recommended Posts

Hi there

I continue to encounter the "Failed to make mounts private: Permission denied" error when trying to setup email piping. (I experience this issue via Forwarding AND POP3 Cron methods).

The permissions for the crons directory, the parent directory to that, and ALL files in the crons directory are ALL set to 755. I have followed instructions and many troubleshooting instructions very very carefully, including trying several different methods of entering the path, and fully re-installing WHMCS in a separate directory! (This is a new site, so re-installing is not a concern right now). The config.php file is showing the path to the install correctly, and the master configuration.php is showing the path to the crons folder correctly.

Does anyone have any feedback?

Share this post


Link to post
Share on other sites

Hi @jburns

That is indeed an odd one, are you using cPanel as your control panel? What is the cron directory set to permissions wise, the files at 0755 should be fine, just checking have you tested pipe.php using 0777 permissions?

Share this post


Link to post
Share on other sites
8 hours ago, WHMCS ChrisD said:

Hi @jburns

That is indeed an odd one, are you using cPanel as your control panel? What is the cron directory set to permissions wise, the files at 0755 should be fine, just checking have you tested pipe.php using 0777 permissions?

Hi Chris, thanks for responding!

I am using cPanel (sorry, should have stated that). The cron directory was set to 0755. I just tried setting pipe.php and the cron directory itself to 0777 and still received the same error.

Share this post


Link to post
Share on other sites

Hey there-

So my web host said there was a core operating system/host node setting preventing the cron from running, so they've moved me to a new server.

And now I'm getting a different error. I've tried different variations of the path to pipe to, and I get the same error (with a different path).

Quote

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

  pipe to |/home/*PATH*/crons/pipe.php
    generated by *EMAIL*
    local delivery failed

The following text was generated during the delivery attempt:

------ pipe to |/home/*PATH*/crons/pipe.php
       generated by *EMAIL* ------

jailshell: failed to create symlink: usr/lib -> /home/virtfs/tyrohost/lib
jailshell: failed to create symlink: usr/lib64 -> /home/virtfs/tyrohost/lib64
jailshell: failed to create symlink: usr/bin -> /home/virtfs/tyrohost/bin Could not exec '/home/*PATH*/crons/pipe.php'

 

Share this post


Link to post
Share on other sites

Hey everyone!

Sorry I realized my last issue was actually due to the path being incorrect -- for some reason the path shown in my Support Departments tab is incorrect. In any case, this is working now! Sorry for all of the messages!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated