Jump to content

PayPal payment gateway not working

Recommended Posts

Hey all,

Whenever I try to "checkout" with PayPal, the whole WHMCS freezes up, can't even do anything on the admin dashboard.

I've removed PayPal and added it back, but the problem persists.

Here's a video of my screen so you see what it's doing.



Link to comment
Share on other sites

4 minutes ago, asheroto said:

Just tried switching to that form and it worked,

you have to remember that Modern hasn't really been updated in years - so if you're using any recent (last few years) version of WHMCS, then you should think about migrating to using standard cart by default.

5 minutes ago, asheroto said:

however, it took a full 60 seconds to go to PayPal (our payment gateway). 

which of the PayPal gateway are you using ?

8 minutes ago, asheroto said:

I tried it a second time - same thing.  I fear users will think it's not working and click out... 

but when you use cc/dc, there is no such delay ?

Link to comment
Share on other sites

6 minutes ago, asheroto said:

I'm using the PayPal gateway on the Feature Gateways tab.

and it's setup correctly with the API details, IPN etc ??

7 minutes ago, asheroto said:

When I use CC/DC (via Stripe) it takes a long time (60 seconds or so) and then finally times out, logging me out of the admin panel too.

then i'd be inclined to think it's not a specific gateway issue and something else is the issue....

does the same thing occur when you use Six and Standard cart together ? that should rule out whether it's a template issue and I suspect if you contacted support, that's the first thing they would tell you to try.

Link to comment
Share on other sites

Yes, the PayPal gateway I chose actually links via my account (had to login).  So it's set up right.  And Stripe is right, too.

It was working before I added PayPal (a day or two ago).  Once I added that it broke!  I have contacted support.

Link to comment
Share on other sites

2 minutes ago, asheroto said:

It was working before I added PayPal (a day or two ago). Once I added that it broke! 

how strange..

1 minute ago, asheroto said:

I have contacted support.

please update the thread with their reply if they find the cause for this.

Link to comment
Share on other sites

Have a look in the hooks folder and get rid of any hooks you aren't using.

We saw a similar issue a few weeks back when any invoice action would lead to a time out and it turned out there was an old quickbooks hook trying to connect to a non-responsive API which was causing the timeout.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated