Jump to content

WHMCS won't install


Recommended Posts

Trying to install WHMCS and running into a lot of problems.


I've tried reinstalling the database and WHMCS.


Eroror: Could not connect to the database!

Please check the database connection details you provided and ensure the mysql user has access to the given database name

MariaDB [(none)]> create database clients;
Query OK, 1 row affected (0.00 sec)

MariaDB [(none)]> create user clients@localhost identified by ‘pass’;
Query OK, 0 rows affected (0.00 sec)

MariaDB [(none)]> grant all privileges on clients.* to clients@localhost identified by ‘pass’;
Query OK, 0 rows affected (0.00 sec)

MariaDB [(none)]> flush privileges;
Query OK, 0 rows affected (0.00 sec)

[root@host ~]# mysql -u clients -p
Enter password:
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 71
Server version: 5.5.44-MariaDB MariaDB Server

Copyright (c) 2000, 2015, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> use clients;
Database changed
MariaDB [clients]> show tables;
Empty set (0.00 sec)



Not sure what I'm missing.


Figured something out. The installation only works if I visit the homepage *AFTER* initiating the install for the first time, which shows the error that there are corrupt tables. Then if I refresh on the installation it will let me configure the administrator account. After doing so, it says install successful, makes the tables, and gives a crit error.

I'm using PHP 5.6 using the latest ioncube loader which is meant to have support for PHP 5.6 with backwards compatibility. WHMCS is not giving an error saying there are ioncube problems though. Ioncube self installed, your script doesn't support 5.6.


The database gives errors during install until I visit the homepage, which gives an error saying tables are corrupt. Then I can continue the install. Even when I complete the install, I get crit errors that WHMCS can't connect to the database.


Using a Linode VPS, nginx, MariaDB 5.55, PHP 5.4, 5.5 and 5.6 tried using the appropriate Ioncube loaders.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated