Jump to content
frynge

Cant login after setting google invisible capatcha

Recommended Posts

I made a bunch of different settings changes, for google capatcha... because I was having multiple bots log in and create fake accounts on my system.  I finally got tired of deleting all the fake accounts, so I changed the capatcha on the account creation and chose google capatcha (the invisible one)

 

Now I finally logged in to create a billing account and sure enough I cannot log in.  On my login screen in the bottom left it says

This site key is not enabled for the invisible captcha.

 

How do I log back in?  I have tried chrome and firefox and both times when i press the login button, it just sits there... it doesnt give an error, it's like I'm not clicking on the button.

 

I need help and would appreciate any help.  How can I log back in?

 

 

Share this post


Link to post
Share on other sites

Hey there @frynge

Thanks for your post, what that means is that you've not put in Google ReCaptcha V3 Keys in your admin area.

In order to get back in you'll need to run the following command on your database which will disable captcha globally

UPDATE tblconfiguration SET value = '' where setting = 'CaptchaSetting';

 

Share this post


Link to post
Share on other sites

How do I run that command on my database?   Which is the easiest way?  I have WHM which allows me access to phpmyadmin... or what else do i do?

Share this post


Link to post
Share on other sites

Okay well I got the command run,   and I got back in to WHMCS.  But that doesn't fix my other issue which was that bots are making constant fake accounts, so i have to continually delete new users.

 

How do I re-enable that or what method should I use to stop bots from making fake accounts.  It said to use google capatcha.  did I install it incorrectly or what?  You'd think that you guys would make this a little more user friendly... bots shouldn't be able to go in there and make accounts anyways.  At any rate, any help would be appreciated

Share this post


Link to post
Share on other sites

@frynge Setup a new ReCaptcha v3 key for invisible recaptcha and then add these keys under Setup > General Settings > Security.

Share this post


Link to post
Share on other sites

I'm having another weird error... I don't know if it's related but it probably is.  A client that I  just billed cannot log in... I told him to delete his cache, but I still haven't received a payment.

 

He said this to me " When I enter my loggin and hit enter (from you shortcut on the email) the information I enter disappears and it shows me 2 empty boxes again to reenter loggin info." 

 
So I am not too sure if these are related, but I told him to delete his cache... but so far no word back from him and I need this payment.  WHMCS was supposed to speed up and help my billing, but I seem to be always dealing with these little issues that slow down my productivity.  The whole reason I set captcha on in the first place was that bots were hacking WHMCS and making constant fake accounts.  I am slowly getting disillusioned with this software.

Share this post


Link to post
Share on other sites

So I've tried to login now as a client, and I cannot login.  I log in and I know i have the right passwords, but it goes back to the password screen and the password and username are blank.  Please help!

Share this post


Link to post
Share on other sites

So I've tried to login now as a client, and I cannot login.  I log in and I know i have the right passwords, but it goes back to the password screen and the password and username are blank.  Please help!

My issue is this.

I have clients login at WHMCS

Normally they just login.... but I made some changes (i set up recapatcha because bots were attacking my website)

We finally got this to work with your help

It works for me to login to admin.... but when clients login now, they enter username and password, and it goes blank. So I can no longer accept payments.

I first requested a payment from a client and then said they can't login. They would enter username and password, and then it goes back to the login screen with blank username and password.

So I then set up my own test account - so when I login it does the same thing to the client. It resets the username and pass to blank and does not let me login and gives no warning.

The only thing I can think that I've set is that recapatcha

In Admin panel-> General Setup -> Settings -> Security

I checked a box Captcha Form Protection (i've tried v2 and v3)
https://docs.whmcs.com/File:Captcha_config.png

When I check this box, my clients can no longer log in. When I set it to
capatch form protection
always on (doesn't let clients login anymore)
Off when logged in (doesn't let my clients login anymore)
Off (I can log back in and so can my clients)

The reason I put on capatcha is because bots were logging in to my billing system and creating unlimited accounts which I had to delete every single day.  Why is this so difficult with this software??

When I set it to on, OR set to to: OFF WHEN LOGGED IN  - when a client tries to login, the username and password goes blank and they cannot login

When I set it totally to OFF the client can then login....

What happens is, you enter username and password and it returns you back to the login screen and the username and password goes blank.

What the heck am I doing wrong?  I can set it back to OFF but that doesn't fix my other issue with bots. Or am I doing something wrong here?

Share this post


Link to post
Share on other sites

Hi Frynge,

Can you please confirm your client area URL so I can take a look?

The ReCaptcha would not cause the form to load again empty, if there is an issue with the captcha it will show an error.

We may need to esclate this to a support ticket but if you can confirm your client area URL i'll setup a test account and take a look

Share this post


Link to post
Share on other sites

@frynge this is because you are using the "Five" template which is not compatible with ReCaptcha 3 please switch to the six theme to resolve this

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated