Jump to content

Upgrading from 7.1.1 to 7.2.3 manually and to 7.4.2 automatically fails

Recommended Posts


I've been working on this for hours and can't get it figured out.

I have a leased WHMCS license through my hosting provider.

I'm currently on 7.1.1, PHP 5.6, MySQL 5.5.59. Server is on Centos 6, EasyApache 4 with PHP 5.6, 7.0, 7.1 and 7.2 active. I've checked that all the extensions (even the optional ones for WHMCS are activated).

My hosting provider has provided me with a full package of WHMCS version 7.2.3. I've got a support ticket in for them to provide me with a later version but they haven't gotten back to me yet.

I've tried doing a manual install as I have done year after year following the manual update documentation to a "T." Upon replacing the files (and even deleting all the existing files (except configuration.php) I just get a "Down for Maintenance" message. The support documents say this message usually happens with patch updates but I'm using a full version and not a patch.

I've tried using the auto update feature within WHMCS and everything goes fine up until the point where it has the hourglass and it will give me an "Update Failed" message with a detailed message that says "A fatal error occurred while fetching the update. Please check to make sure your memory limits and execution time are set to the recommended values." I've checked this and my memory limit is set to 128M and max_execution_time was set to 60 but I even increased it up to 600.

I've even updated my account to run PHP 7.0, 7.1 and 7.2 with no success as well.

My goal was to stair-step my WHMCS upgrade to WHMCS 7.4.x then upgrade my hosting account to use PHP 7.2 then upgrade to WHMCS 7.5 but I can't even get past the first step.

I'm just not sure why I'm having so many issues with this upgrade. I've done this dozens of times in the past as I've been using WHMCS for many years now.

I've Googled and searched all of WHMCS's documentation with no avail. I'm thinking that the 7.2.3 package my hosting provider has available for me is possibly corrupt?

Link to comment
Share on other sites

Of course after I typed out my initial post I figured out a way to get the update to work. :D

Instead of unzipping the whmcs package on my computer and FTP'ing all the files up I uploaded the zip directly to my file server then using cpanel's file manager I extracted the files into a temp directory and then moved them to my whmcs folder (/billing) which overwrote the files and allowed me to then visit my whmcs install admin page and go through the update process successfully.

I thought I would just posted this message and my solution in case anyone else was having this same issue.

I was using Filezilla on a Windows PC. It didn't show any errors when transferring the 6k+ files to my server and I did select to overwrite files.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Trying to get things updated again and here is where I'm at...

I'm on 7.2.3 and the auto updater is showing I can update to 7.4.3. I try and process that and it fails. I checked the log in the database and every time I try the update it logs the following in tblupdatelog:


exception 'Whoops\Exception\ErrorException' with message 'Allowed memory size of 134217728 bytes exhausted (tried to allocate 55694889 bytes)' in /home/*********/public_html/billing/vendor/composer/composer/src/Composer/Util/RemoteFilesystem.php:402 Stack trace: #0 /home/*********/public_html/billing/vendor/whmcs/whmcs-foundation/lib/Utility/Error/Run.php(0): WHMCS\Utility\Error\Run->handleError(1, 'Allowed memory ...', '/home/*********/...', 402) #1 [internal function]: WHMCS\Utility\Error\Run->handleShutdown() #2 {main}

{"time_lapse":25,"memory_usage":"80 MB","memory_peak_usage":"80 MB"}

I've got 128M of memory available and the error is only saying it's trying to allocate ~55 MB and the 'extra' section says peak usage was 80 MB.

I'm just confused because it's acting like it's maxed out on memory but clearly isn't.

I'm kind of in a pickle right now because I had a new client sign up today and purchase a hosting package and domain registration. I can't seem to get WHMCS to connect to cPanel in order to create the hosting account properly. When I go to the hosting plan and I can run the 'create' function manually and it says 'success' but when I look at WHM accounts list it doesn't show up.

I went to check my server connection at Setup > Products/Services > Server > Edit and then do a "Test Connection" it gives me a "FAILED: Array" error message. I've double/triple checked my login credentials and even generated new API tokens with full permissions. I've tested with and without SSL and it still errors out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated