Jump to content

Can it be this difficult to upgrade?


Recommended Posts

Okay, I have tried about 15 times now, I think, but have failed to upgrade WHMCS. I am not exaggerating one bit. The only time it sort of worked, there were still some issues and Matt said I was missing some files. But, I couldn't set it right.


I upgrade a CMS like drupal fairly frequently, so I just can't get what's causing the problems. Here are the issues I have encountered:


1.) When I upload the new files, the folders are overwritten, but not the .php files. I can't set them to 777 because I am running phpsuexec where the highest permission is 755, but WHMCS then says the config file needs to be 777 and hasn't passed the test.


2.) I zapped the whole install after taking a backup of the db and uploaded 3.4.1. This time it proceeded fine like it would on a fresh install, but it insisted on creating the whole db afresh, so I had to delete all the stuff in the old db (I had a backup, right?) so that the new tables could be created. But, if I did this, I couldn't figure out how to bring the old data back.


I am totally exhausted doing this. Any suggestions?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated