Jump to content
Pheonix

Country field not working in postman API

Recommended Posts

Hello,

We have used POSTMAN API to add a client in WHMCS. We are getting the below error when we try to add.

 

You did not provide required custom field value for Countries
 
We have added country code as 'GB' however it is not working. We have followed the below URL for API endpoint.
 
 
Any help would be appreciated
 

Custom_field.png

Share this post


Link to post
Share on other sites

The error is referring to a Client Custom Field that is named exactly Country and set as required (Setup > Custom Client Field). It's not the country field of WHMCS.

That said, you have 3 options:

  • Specify Country custom field in your API call
  • Make it optional
  • Delete it

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated