Jump to content

PayPal IPN handshake invalid


Recommended Posts



I recently moved to a new domain and server, and ever since doing so I've had difficulties with PayPal IPN.


It seems that the IPN handshake has failed. I have already recompiled Apache with CurlSSL, this did not fix it.


Server information:


PHP version: 5.4 (Native) - On another note, whenever I select any other php version, the WHMCS client area throws 500 errors


Any help in resolving the issue would be appreciated!


- - - Updated - - -


Additionally, here is an example of the IPN message:


transaction_subject => 644
payment_date => 12:21:03 May 26, 2014 PDT
txn_type => web_accept
last_name => 
residence_country => NL
item_name => Duco Hosting - Invoice #SGHT201405_382
payment_gross => 
mc_currency => EUR
business => paypal@ducohosting.com
payment_type => instant
protection_eligibility => Ineligible
verify_sign => BLABLABLABLA
payer_status => verified
tax => 0.00
quantity => 1
receiver_email => paypal@ducohosting.com
first_name => cas
payer_id => NOPENOPENOPE
receiver_id => NOPENOPENOPE
item_number => 
handling_amount => 0.00
payment_status => Completed
payment_fee => 
mc_fee => 0.01
shipping => 0.00
mc_gross => 0.01
custom => 644
charset => windows-1252
notify_version => 3.8
ipn_track_id => 4b47d85a07


I have removed some information that I deem personal.

Link to comment
Share on other sites

have you tried using the paypal sandbox to test this, with sandbox you can also test to make sure your getting connection if you plug in the data manually. I assume when you say invalid you mean it failed connection. OR do you mean that it made connection it just didnt pass it back to you via IPN?

Link to comment
Share on other sites



It is getting the initial notification, because that quoted information came from the WHMCS gateway log.

As far as I can tell, all information was passed to my server by PayPal, but there was some authentication issue (I assume) that made it stop. I'll test with sandbox and post back the results.

Link to comment
Share on other sites

The issue has been resolved. Here's how I did it:


- Even though the WHMCS docs say that the encoding Windows-1252 would work, it didn't for me. I followed the instructions on the docs page to enable replies in the same encoding as sent messages, but this didn't work.

- To fix it, I simply changed my IPN encoding language in paypal to the same I had set in WHMCS->setup->general configuration->localisation.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated