Jump to content

Taxes not added to Billable Items


Recommended Posts

I've searched the forum, but have only found threads relating to the opposite problem I'm having....


I need tax to be automatically added to every invoice generated via billable items. It is my understanding by some other threads, that WHMCS is supposed to function like that by default.


I went in to tax rules, and checked "billable items", but it did not seem to have an effect. Every month, my invoices are generated without taxes.


Any thoughts would be appreciated.


I'm using 4.5.2


Thanks in advance.

Link to comment
Share on other sites

Thanks for the quick response.


Yes, I have enabled "Tax Enabled" and I use taxes regularly with no problems for manual invoices and products.


I'm generating monthly invoices for non-product items (such as labor or monthly contracts), so I have "0" in hours, since all I want on the invoices are a description and amount.

Link to comment
Share on other sites

...Do I need to have "Custom Invoices" checked under tax rules?


Under setup >payment > tax rules > apply tax, wouldn't you want everything selected?


Some other things to check -- that client should actually pay tax based on your tax rules, and client > profile > tax exempt is deselected.

Link to comment
Share on other sites

  • 10 months later...

Just a bit of help for those who found this from a Google search.


We noticed that after upgrading from v4.x.x to 5.1.2, any billable items generated where not adding tax. Tax had automatically being added in the past to billable items without any problems or extra settings needed.


Upon investigating Tax Rules (Setup -> Payments -> Tax Rules) we noticed there is now a series of new boxes (Apply Tax to). Billable items and custom invoices were both unticked, which we presume are left in an unticked default state following the upgrade.


In order for tax to apply to your billable item, make sure the tick box as mentioned above is ticked. This should resolve the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated