Jump to content

cron & suhosin memory_limit error


Recommended Posts

Hi all,


Occassionaly when the WHMCS cron runs (not every time) I get the following error (account info changed):


Mar 10 03:00:01 z06 suhosin[2488]: ALERT - script tried to increase memory_limit to 536870912 bytes which is above the allowed value (attacker 'REMOTE_ADDR not set', file '/home/myacount/public_html/clientarea/cmsadmin/cron.php', line 0)


It seems the cron for WHMCS is trying to increase the memory limit to 512Mb to run.


I know when I get this same error during a wordpress update (for example) the update usually fails. HOWEVER, I am getting my cron e-mails, and when I check WHMCS, it apears it has updated overnight. (I check bandwidth useage)


So I have a question... Is there somewhere I can edit a file within WHMCS to correct this, or am I going to have to edit my php.ini file & suhosin settings. (I have tried that with a couple different settings, but still get occassional errors)



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated