Jump to content
  • 0
Sign in to follow this  
Georges

Disable sending of invoice emails automatically

Question

Is it possible to completely disable whcms from automatically sending invoice emails on new (created by an admin only or in general) orders ?

 

I tried to disabled any possible option under the configuration menu, but whmcs still immediately sends an email to the specified email address.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

This is only possible if you run the invoice generation manually from the admin homepage instead of using the cron job. When click the Generate Invoices button on the admin homepage you get a dialog asking if you want to send emails or not.

 

Matt

Share this post


Link to post
Share on other sites
  • 0

Thanks for your quick reply.

 

That works.

But what I meant is, when I, as an admin, add a new client, and (still as an admin ) add a new order to that client, whmcs sends an email to that client regarding a new invoice which has been created ("Customer Invoice").

 

What I want to know is if it's possible to disable sending that email automatically ?

Share this post


Link to post
Share on other sites
  • 0

when you do it as admin there is a checkbox you can uncheck for sending the client an email. It's how I manually imported all clients and invoices without sending emails.

Share this post


Link to post
Share on other sites
  • 0

Ah ok, yes, to avoid that you must set the user to PayPal Subscriptions when adding the order. This way no invoice is generated and therefore no email sent about it. As PPH rightly says, you can prevent the order confirmation email being sent via a tickbox. Then once the order is added, you can edit the account and set the correct next due date and payment method so an invoice will be generated when it is next due.

 

Matt

Share this post


Link to post
Share on other sites
  • 0

PPH: Thanks, but by default that checkbox ("Send Order Confirmation to Client when Completing Order") is unchecked, and I still get the before mentioned email. When I do check the checkbox, I get two emails:

"Order Confirmation"

"Customer Invoice"

 

Matt: I set the payment method to the actual one, "Bank Transfer". When I set it to "PayPal Subscriptions" as you suggest, whmcs doesn't send an email to the client anymore :-).

 

So is it a bug that it still sends an email even if the checkbox isn't checked ?

 

 

Thank you both for your quick replies :-)

Share this post


Link to post
Share on other sites
  • 0

Yes, when you add the order you must choose paypal subscriptions and change it later. When you accept the order there are more areas to look for a send email check mark fields. Always look around before proceeding to the next step :wink:

Share this post


Link to post
Share on other sites
  • 0

I am doing this like that:

 

I am creating a new user with one of my email address. Then make all the things (orders etc.). When everything is ok, i am changing the email to the right one.

 

This may be another solution for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated