Jump to content

worldpay authmode > E or A


Recommended Posts


Just updated to whmcs 3.8.1 then to 3.8.2 and new orders no longer work correctly through worldpay. the issue seems to be with authmode changing from E to A


I have 2 worldpay installations. In the past all payments with pre-auth went to installation B and all none pre-auth went to installation A


Now I find that all new orders now go to Installation A but futurepay payments still go to B


Hope that makes sense :)


I had previously not set the capture delay in worldpay so that may be the issue. From what I have read worldpay no longer use authmode E ?


Any help would be appreciated.



Link to comment
Share on other sites

  • 2 weeks later...



Worldpay changed their systems some time ago so that you can set the capture delay via the Worldpay site. This then makes all transactions go pre-auth automatically and then after X days (that you have set) it will automatically release them to full auth.


So, that function is pretty much useless now.


Are you using Invisible?

Link to comment
Share on other sites


No I am not using invisible. The problem I have is that payments are going to the wrong worldpay account ID. Worldpay have told me I need to pass the following info when using authmode A / capture delay or authmode E if capture delay is off:


<input type="hidden" name="accId1" value="myaccnumber">


If I do not send that info then my payments go to the wrong worldpay acc id, I have 2 one for whmcs and one for awbs.

Link to comment
Share on other sites

Matt has sent me 2 new worldpay files with the <input type="hidden" name="accId1" value="myaccnumber"> included so now my payments go to the correct accid.


I have 2 UK installations and 2 accid's.


Here is what worldpay said:


Currently both your merchant codes WPACCxxxxxx46 and WPACCxxxxxx90 are setup with Capture Delay set to 'OFF' i.e. setup for Pre-Auth. Therefore if the accId1 parameter is not passed with the preference then the funds will be automatically directed to the first available account.


If the capture delay on the 2 accounts were different then if you pass authMode=E then it will direct the funds in the pre-auth account and authMode=A into the immediate capture account.



Whmcs currently sends authmode A when using futurepay but uses authmode E when using worldpay invoices. All is working fine now with the new files.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated