Jump to content

Setting Up Hosting Account | Doesn't Create cPanel Account (No Errors Displayed)


Recommended Posts

So I setup my server with the hostname as server ip. I put in the correct server ip address. The server credentials are my root username and the hash i generated. I selected the cpanel option. Everything is setup as it should, and when a new order comes in, WHMCS treats everything as if it worked correctly, however in the welcome hosting email the cpanel user and password areas are blank and the client side in their account their are no cpanel or webmail login links. In WHM the account is not under list accounts.

Link to comment
Share on other sites



First I would recommend checking the Activity Log (Utilities -> Logs -> Activity Log) for any errors. If there aren't any errors in there then the next step would be to enable the Module Debug Log. This can be done from the same menu, only instead of Activity Log click on Module Log. Once on that page click the Enable Module Debug button and then try accepting the order again. Any errors will be displayed in there.


Those steps also assume that you have auto setup enabled if you do not have that enabled packages won't be created automatically.


If you still are having trouble getting this setup, you can submit a support ticket for further assistance!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated