Jump to content

5.2.3 Cron - Payment Capture not attempting Overdue Invoices


Recommended Posts



When we try to 'Attempt CC Captures' from within whmcs for all due invoices, or re run the cron ( as we have a problem at this time ) it is only attempting to charge credit cards that are due on today's date.


The automation Settings - 'Tick this box to only attempt the payment automatically once and if it fails, don't attempt it again' is not selected.


Prior to the upgrade, on the daily cron ( we only run it once a day ) it would attempt to charge ALL due or overdue invoices.


I have a ticket IGR-195329 open, but has anyone else come across this ?

Link to comment
Share on other sites

We have the same issue since we upgraded a few days ago. I'm willing to bet there are more if they look at their cron job report and compare the day before the upgrade and the day after they will see them. If you process a decent amount of daily transactions it definitely stands out.


I opened a ticket after scanning the forum yesterday to ask about it and so far do not have a resolution.


We are also having clients that try to pay manually with their CC report that it does not work, they get an "error 1" message, the charge attempt doesn't even hit the gateway options we have, but if we submit the charge attempt from the admin side it goes through.

Link to comment
Share on other sites

We have commissioned a custom php script so we can do this ourselves, as we have had no update on our ticket regarding the problem, or even acknowledgement, which is so disappointing.


If we have the script in a working format, before WHMCS release a fix or at least respond to an old ticket, I will post it here for download.

Link to comment
Share on other sites

No due or overdue invoices are being processed with the daily cron since upgrading to 5.2.X - something really wrong. The cron job runs but the "WHMCS Cron Job Activity" doesn't get generated to show how many transactions were processed or failed.


The solution to this problem was too easy - all I had to do was "save" the "Setup/Automation Settings" to make things work again. Apparently a number of flags changed in the WHMCS back end and nobody at WHMCS bothered to let us all know that we should be re-saving our settings to rewrite those variables so the new CRON.php would know what to do with them. It was "segfaulting" when the cron job ran before those settings were saved. Once settings were re-saved the cron job performed perfectly. WHMCS developers should have anticipated this and forced a re-save of those settings during the upgrade process to 5.2.X to prevent this horrifying result. I'm glad it was easy to resolve.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated