Jump to content

Authorize.net CIM error E00003 HELP!


Recommended Posts

Im trying to integrate Authorize CIM, got my api entered in and went test it out and i get an error. The normal authorize.net gateway works fine, so i know the api information is right.


What is the problem?? I entered a support ticket, but support has let me down a lot over the last month and a half with other issues unresolved.




Invoice ID => 1314

User ID => 1

Amount => 1.00

UserID => 1

Action => CreateCustomer

XMLData => <?xml version="1.0" encoding="utf-8"?><ErrorResponse xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="AnetApi/xml/v1/schema/AnetApiSchema.xsd"><messages><resultCode>Error</resultCode><message><code>E00003</code><text>The 'AnetApi/xml/v1/schema/AnetApiSchema.xsd:cardNumber' element is invalid - The value '' is invalid according to its datatype 'String' - The actual length is less than the MinLength value.</text></message></messages></ErrorResponse>

Link to comment
Share on other sites

  • 1 month later...

If i remember correctly, i was moving from a Payflow pro account gateway to an authorize.net cim. For it to work properly, i had to clear all the gateway id's and credit card (last 4 digits) data from the WHMCS database for all the clients and they had to manually again pay once then it was being stored by CIM for recurring transactions. Everything is running smooth now.. but a little hassle for clients. Please dont completely rely on me... im not a complete programmer.. i just know support gave me nothing from WHMCS.


Things to try:


under General Settings->Security: make sure that "Disable Credit Card Storage" is UNCHECKED. I also removed the option from the check out page in my theme preventing people from checking Do not store credit card, because if they checked it it will throw a payment error. (they can always remove it from their client account later in their WHMCS Login)


If you want to try go ahead and make a brand new test client account try and pay a test invoice (dont check "do not store credit card") and see if it goes. If it goes fine, then that is a good indication the current stored data for clients is conflicting with the new gateway. Like i said i cleared out the gateway id's and store 4 digit CC's from the database.


*******ALWAYS MAKE A BACKUP ****************


Link to comment
Share on other sites

Just found another post with an answer that worked for me at http://forum.whmcs.com/showthread.php?45399-Authorize-net-CIM-testing-CC-keeps-declining-how-do-you-test/page2&highlight=authorize.net+cim.


Contrary to what you might think, you should not tick the setting to "Disable Credit Card Storage" in Setup > General Settings > Security as that will disable entry by a client.


It must be enabled to show the credit card payment form and allow clients to update their card details, but the fact you are using the Authorize.net CIM module will prevent the details being stored locally in WHMCS and instead store them only on the remote system.


After disabling the checkbox, it worked perfectly.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated