Jump to content
Sign in to follow this  
cyberneticos

Directadmin Sync Report (DASR)

Recommended Posts

Hello,

 

Yes, i fill all this section.

 

 

// ------- whmcs dabase data. same as configuration.php -------------------------------

$db_host = "localhost";

$db_username = "";

$db_password = "";

$db_name = "";

 

// ------- whmcs api to decrypt server passwords ------------------------------------------------

 

$apipath = "";

# URL to WHMCS API file

$adminuser=""; // your main whmcs administrator username

$adminpass=""; // your main whmcs administrator password

 

// -------- change this URL to your image folder. leave trailing slash --------------

$imgroute="images/";

 

// -------- email address where reports get sent to/from ----------------------------------------

$useremail = "";

 

 

 

Hi citeglobe. Did you edit the config file ?

Share this post


Link to post
Share on other sites

Hello,

 

The version of Whmcs is 4.0.2

 

Yes, the system display the real numbers. It's me to hidden them.

 

 

 

What version of WHMCS are you using ? Are the xxx real numbers that you are hidding,. or is that how it really shows ?

Share this post


Link to post
Share on other sites

OK, this has only been tested in 4.1.x so, maybe that's the problem. I can't think of anything that would cause that. Make sure that the directadmin admin password in the servers section works (click on the login button)

 

Make sure your firewall is not blocking outgoing 2222 port TCP.

Share this post


Link to post
Share on other sites

Problem 1) I am not using Directadmin Server, But i am using DAPLUS (free addon in contribute's forums)

 

2) after i set Directadmin in servers, i get error

API error: Not receiving decrypted password

array(2) { ["result"]=> string(5) "error" ["message"]=> string(24) "Invalid IP 202.52.123.123" }

Share this post


Link to post
Share on other sites

Hi guys, I can't seem to replicate the problem, I'm running 4.2.1 , and it's running fine.

 

Let's try something, if you can send me the files you have downloaded, including config file (take out passwords), send it to me in a zip, and I will try running it from my environment.

 

It doesn't matter what DA module you are using in DA, becuase I don't use WHMCS to communicate with DA, I use DA's API directly.

 

Thanks !

Share this post


Link to post
Share on other sites

Ok found the problem and need your help.

 

Problem is that is DOES use the directadmin native module, so I need your input since I don't have DAplus.

 

Can you tell my what servertype directadmin plus is ? If you go into your DB, you can see this (I don't have it installed in WHMCS) in tblservers. The native servertype is "directadmin" , so I am guessing it will be something like "daplus" or similar.

 

Thanks!

Share this post


Link to post
Share on other sites

NEW UPDATE: DASR v.0.6 RC1

 

FIX: Now supports any Directadmin module (DAPlus, etc.)

 

Tested on WHMCS v.4.2.1 and Directadmin v.1.35.1

 

Free Trial Download: https://www.cyberneticos.com/soporte/index.php?_m=downloads&_a=downloadfile&downloaditemid=10

 

Existing customers can download the new version from thier client area at cyberneticos.com

 

Cheers, and thanks to LemonBarley for his help!

Edited by cyberneticos

Share this post


Link to post
Share on other sites

meh. still the same

 

 

Server:

 

API error: Not receiving decrypted password

array(2) { ["result"]=> string(5) "error" ["message"]=> string(24) "Invalid IP 202.52.123.123" }

 

 

well maybe its my fault i am still running 4.0.2 (i cant update there is too many customisation, i hate the most to upgrade there is no solutions to save the custom customisations)

Share this post


Link to post
Share on other sites

Ok, this must be an issue with your password, or firewall or something. I am using 0.6 RC1 and works perfectly.

 

Please make sure your passwords in servers are they ones for admin in Directadmin. Make sure ports are open 2222 tcp out. etc..

Share this post


Link to post
Share on other sites

Hey,

just curios:

why isn't this a WHMCS module?

why does it have to be an independent script?

Share this post


Link to post
Share on other sites

why isn't this a WHMCS module?

 

--Because it's just a php script.

 

why does it have to be an independent script?

 

--Who says it has to ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated