Jump to content
Sitecenter

Paypal IPN setup

Recommended Posts

I've just changed Paypal accounts and in the admin area of WHMCS it says to 'enable IPN but leave the url blank'.

 

It now appears that this isn't possible and if you wish to enable IPN you must enter a valid url. How do we get round this?

Share this post


Link to post
Share on other sites

Sitecenter,

 

you should be able to leave the url box empty, but it is pre-filled with "http://" , just make sure you clear that from the box.

Share this post


Link to post
Share on other sites

Boy howdy, you're right! I only just set mine up less than 2 weeks ago.

 

You might have to submit a ticket on this.

Share this post


Link to post
Share on other sites

I just spoke to Paypal and they told me that we must enter the url in their system. That is the only way that Paypal con communicate with WHMCS

Share this post


Link to post
Share on other sites

Whmcs submittes the notify URL as part of the payment submission process to whmcs. Therefore paypal will return to that notify, this _should_ override the one that is in the paypal configuration. If you follow the instructions in the wiki you should have no issues. I have configured my paypal like that and all my transactions work file. Just check that you have your WHMCS url settings correct in your configuration.

Share this post


Link to post
Share on other sites

From the Wiki:

 

You need to enable IPN and leave the callback URL blank. The callback URL is pre-populated with "http://", which must be deleted.

 

So if I put something in there who's to say it will definately override it?

 

"Just check that you have your WHMCS url settings correct in your configuration." - Where do you mean? The only option I have is to put in my Paypal email address...

Share this post


Link to post
Share on other sites
"Just check that you have your WHMCS url settings correct in your configuration." - Where do you mean? The only option I have is to put in my Paypal email address...

 

Thats correct.

That should be all you need to do.

What is the probelm that you are not having. You can use ipn without setting the IPN variable on the paypal. Just put in your paypal email in your whmcs config then leave the box blank in the paypal config. ;)

Share this post


Link to post
Share on other sites

I have not entered the IPN.

There are 2 types of IPN.

The ipn that is on the paypal site will send ANY payment that you get to your whmcs scripts. Eg if i was to paypal you some money to paypal@youraddress.com it would notify you. However using the whmcs form it will tell paypal to notify your whmcs of the completion of that payment that is being made. This is enough to be able to verify the success/failure of the whmcs payment/transactio

 

 

ps. Yes I have posted the same in 2 threads... people don't seam to be able to search :(

Share this post


Link to post
Share on other sites

Shaun

I don't agree with you. If you want the IPN on you need the url. It has been confirmed by Paypal. I will open a support ticket with WHMCS and let everyone know the outcome.

Share this post


Link to post
Share on other sites
Shaun

I don't agree with you. If you want the IPN on you need the url.

 

This is the way im using it and im still getting payments ;)

As i have said there is IPN and a "notify url", these are 2 different paypal notification concepts.

WHMCS uses the Notify URL which is like IPN for that one transaction. The IPN in the paypal setup is notification for ALL TRANSACTIONS wether sent via whmcs or anyother method.

Trust me i'm not just a user but also a developer. If that was needed and changed in the last 2 weeks ALOT of whmcs users would be complaining.

 

Have you just tried receiving a payment using whmcs without IPN setup in the paypal profile ?

Share this post


Link to post
Share on other sites

PayPal recently did an upgrade and it now won't let you save a blank url.

If you already had IPN setup before paypal did the upgrade you won't notice the diference or won't have a problem (if at all).

Go to your paypal account and edit your IPN settings and try to save it. (DON'T CLICK THE DISABLE BUTTON) some images attached

 

However as Shaun said WHMCS sends a Notify URL which should override the IPN url setting at paypal.

My IPN was already setup before their upgrade and I have had no problems at all.

1.jpg

2.jpg

Share this post


Link to post
Share on other sites
Well if someone fancies testing this then let me know. I can refund any payment straight away.

 

Sounds weird but you can paypal to your own acct from paypal.

You can also try an add funds of 10c from your CC.

Share this post


Link to post
Share on other sites

Here is the answer from Matt: " If there has been a change then it must be on PayPal's side. If you can't leave it blank just enter WHMCSURL/modules/gateways/callback/paypal.php"

Share this post


Link to post
Share on other sites
Here is the answer from Matt: " If there has been a change then it must be on PayPal's side. If you can't leave it blank just enter WHMCSURL/modules/gateways/callback/paypal.php"

 

Bit of a pisser by PayPal if you want to receive payments into 2 systems from a single Paypal account... :(

Share this post


Link to post
Share on other sites

WHMCSURL/modules/gateways/callback/paypal.php, does WHMCSURL mean my url to WHMCS or

put "WHMCSURL/modules/gateways/callback/paypal.php" exactly as it is written here?

Edited by Texas Juan

Share this post


Link to post
Share on other sites

Hi Juan

The url that Matt has asked me to add is not working for me. I have tried different urls but not luck.

 

Has anyoned had any luck with this?

Share this post


Link to post
Share on other sites

I just did a test purchase on my installation. The invoice payment confirmation email has this in the header:

 

X-PHP-Script: ...[removed].../modules/gateways/callback/paypal.php for (IP#)

 

I did set up the IPN just before they stopped allowing a blank url.

Share this post


Link to post
Share on other sites
Hi Juan

The url that Matt has asked me to add is not working for me. I have tried different urls but not luck.

 

Has anyoned had any luck with this?

 

I haven't tested it yet. I'm still setting up the rest of my stuff. I will test tonight for sure and post.

Share this post


Link to post
Share on other sites

Only issue now is if you have a Paypal account which takes payments from different sources, such as hosting and then a webstore.

Share this post


Link to post
Share on other sites
Only issue now is if you have a Paypal account which takes payments from different sources, such as hosting and then a webstore.

 

Exactly - which is why we haven't dared go into our Paypal settings recently!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines