Jump to content
evolve hosting

Creating Product Groups - Not Showing up until Refreshing Screen

Recommended Posts

Posted (edited)

Create new product group

See the changes saved success message

Click 'back to product / services'

The group doesn't show up until you refresh the screen

Same thing happens when adding a product - it doesn't appear in the list until the screen is refreshed

Edited by evolve hosting

Share this post


Link to post
Share on other sites

This is certainly strange since I am not able to replicate this on my test install. Can you please check for any local server side caching and disable them if there are any? 

Share this post


Link to post
Share on other sites
5 hours ago, WHMCS Sachin said:

This is certainly strange since I am not able to replicate this on my test install. Can you please check for any local server side caching and disable them if there are any? 

I don't have anything outside of the norm installed that I'm aware of. I'm using Firefox 99.0.1 that only has adblock, shortshare, Facebook container and 1password extensions installed.

Share this post


Link to post
Share on other sites

Please accept my apologies for the misunderstanding. I meant any local caching on the hosting server where WHMCS is installed (like memcache, redis, opcache or any other kind of caching mechanism). If there are is any such caching mechanism installed, please have it disabled to resolve this issue. 

Share this post


Link to post
Share on other sites

@WHMCS Sachin mod_authn_socache and mod_expires and php74-php-opcache are installed. You're saying I can't use any of these with WHMCS? I think I'll just refresh the screen to keep the benefits of opcache.

Share this post


Link to post
Share on other sites

Hi @evolve hosting,

The presence of such caching measures would indeed explain why you're seeing stale data occasionally; the stale version of the page is served instead of the one reflecting the latest changes.

Perhaps the caching settings on your server are configured a little liberally, and could be tweaked so that your changes are reflected immediately without the need to hard refresh?

Share this post


Link to post
Share on other sites
Posted (edited)
On 25/04/2022 at 6:51 PM, WHMCS John said:

Hi @evolve hosting,

The presence of such caching measures would indeed explain why you're seeing stale data occasionally; the stale version of the page is served instead of the one reflecting the latest changes.

Perhaps the caching settings on your server are configured a little liberally, and could be tweaked so that your changes are reflected immediately without the need to hard refresh?

It would be great if whmcs could publish their recommended settings for having some sort of caching for cPanel/Apache and other web servers to improve whmcs performance without compromising its functionality.
Thanks.

Edited by Mandalorian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated