Jump to content
pepsichanhvn

Error add vcenter in WGS vmware module !!!

Recommended Posts

Hi all,

I've already fresh install WHMCS 8.2 and add-on vmware module in CentOS 7.9

But i can't add vcenter to vmware module, it's respond "Bad request" as below pic.

My vcenter is still running, i can curl my vcenter server, it respond ok.

WHMCS : 8.2 , WGS VMware module 3.09, VCSA : 7.x

Please help me to fix it ?

image.thumb.png.9942df2ccf5a07b822c9ff1f06cd361d.png

 

image.png.07fe4796cf82bd55353cd25bb7174074.png

Share this post


Link to post
Share on other sites

Being a third party module @pepsichanhvn you'd be best to reach out to @WGS directly, however I'd also suggest enabling your Module Log and seeing if something shows in there that will point you to the error.

Share this post


Link to post
Share on other sites

@pepsichanhvn We are  sorry to hear that you are having issue with our module.

Please make sure that you have entered the vCenter IP Address/hostanme with http or https and also make sure there is not slash "/" after the vCenter URL For eg.  https://vcenter.whmcsglobalservices.com and not like this vcenter.whmcsglobalservices.com, https://vcenter.whmcsglobalservices.com/ 

 

if you are  still having issue please open the ticket here https://whmcsglobalservices.com/members/submitticket.php?step=2&deptid=5

Share this post


Link to post
Share on other sites
On 9/2/2021 at 1:33 PM, WGS said:

@pepsichanhvn We are  sorry to hear that you are having issue with our module.

Please make sure that you have entered the vCenter IP Address/hostanme with http or https and also make sure there is not slash "/" after the vCenter URL For eg.  https://vcenter.whmcsglobalservices.com and not like this vcenter.whmcsglobalservices.com, https://vcenter.whmcsglobalservices.com/ 

 

if you are  still having issue please open the ticket here https://whmcsglobalservices.com/members/submitticket.php?step=2&deptid=5

Thanks @WGS it's worked for me, 

I removed the slash "/" after my vcsa url.

Share this post


Link to post
Share on other sites
On 9/3/2021 at 11:18 PM, pepsichanhvn said:

Thanks @WGS it's worked for me, 

I removed the slash "/" after my vcsa url.

Great!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By ModulesGarden
      Welcome to the entire WHMCS community!
      We are bringing even more great news today. We have compiled a short list of modules for WHMCS that we would like to develop in the near future. 
      All of them are equally important to us so we thought you might help us with deciding on their release order.

       
      Be sure to stop by our Forums and vote for your favorite options!
      The poll is open to everyone and no account is required to join in. But of course, we will be delighted to have you in our ranks! 
    • By WGS
      A new update of our Vmware module is released. the new 2.0.4 version is available to download. 
      Whats New!
      New Feature:
      Now you can choose network adapter on which you want to create the new VM. Bugs Fixed:
      Delete IP from IP pool - Fixed - You can now easily delete IP's from IP Pool  
      Checkout the module at: https://whmcsglobalservices.com/vmware-whmcs-module/
    • By WGS
      HI,

      WGS is ready with latest updates in VMware module. On the high demand & suggestions of our existing customers we have done some changes in our VMwaremodule. Our users were facing the issues related to console and IP pool. So we worked really hard and found the solution for this and now we successfully fixed it, now users can easily use our VMware module without any hesitation. We have done the changes in our VMware Module version 1.0.7.   
      Here I am sharing the details of the changes made by us in our latest module:
       
      New Features Added / Latest Updates of VMware Module
      1.)    Our existing users were facing the difficulties related to console issues, on the high demand and request of our valued customers we fixed the issue of console. Now console is working smoothly with our latest version. We have added one more console (VMRC console) for UI view in client area. It will work with both http and https. So users will not face any difficulties to access the console. Initially users were facing the issues when it was not working with https. Now it is resolved and easily working with https with VMware version 1.0.7.
      2.)    We have fixed the IP issue. Whenever VM was created if by mistake clicked on the delete button IP was getting delete from the assigned IP pool. Now in current version we have fixed the issue assigned IP cannot be delete until the VM got free.
      3.)    Our latest version of VMware module supports latest version of vCentre 6.5. 

       
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated