Jump to content
Walther

removing credit card on client area

Recommended Posts

Using Stripe (or any other token-based gateway), few data of client's credit card are recorded (last 4 numbers, expire date)
The user can edit this data, but is not able to delete it (only in admin area it's possible to delete it... so the user should open a ticket, asking for deleting these data, and admin should delete it manually... time consuming and annoying)

An API to delete a recorded credit card does exist: DeletePayMethod ( https://developers.whmcs.com/api-reference/deletepaymethod/ )

So, a fix should be:

  • add a button "Delete" in client area in /index.php/account/paymentmethods/1234
  • this button calls the DeletePaymethod API

My issue: how to insert such a button in this page?!?!?! 
please help!

 

Share this post


Link to post
Share on other sites
Posted (edited)

Which version are you using? There was a bug in v7.10.2 (and maybe earlier) but it was fixed in 8.0 and above for the customer and admin to delete payment methods.

Edited by evolve hosting

Share this post


Link to post
Share on other sites

Settings -> Security tab -> Allow Client Pay Method Removal checked should do the trick. 

Share this post


Link to post
Share on other sites
6 hours ago, evolve hosting said:

Which version are you using? There was a bug in v7.10.2 (and maybe earlier) but it was fixed in 8.0 and above for the customer and admin to delete payment methods.

The issue, AFAIK, there's on any WHMCS version: in client area, in /index.php?rp=/account/paymentmethods/xxx a "delete" button does not exist, so the user is simply not able to delete a recorded credit card...

(I've tested both 7.10.2 and 8.0.4 ... same issue on both version)

Share this post


Link to post
Share on other sites
3 minutes ago, Walther said:

The issue, AFAIK, there's on any WHMCS version: in client area, in /index.php?rp=/account/paymentmethods/xxx a "delete" button does not exist, so the user is simply not able to delete a recorded credit card...

(I've tested both 7.10.2 and 8.0.4 ... same issue on both version)

Take a look at the suggestion from @steven99 above

Share this post


Link to post
Share on other sites
14 minutes ago, steven99 said:

Settings -> Security tab -> Allow Client Pay Method Removal checked should do the trick. 

You got it!!!!! Thanks!
(But why WHMCS configuration parameters are randomly scattered around?!?!?!?! 😮 )

 

Share this post


Link to post
Share on other sites

How are they randomly scattered around?  General / overall settings are in the settings area.   Everything else is covered in their own areas from products and servers to domain registrars.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated