Jump to content

Recommended Posts

Ive gone through - and im not really that impressed with 8.1 after upgrading from 7.x .

 

Someone (whmcs) really needs to go through and squash interface bugs - it feels untested.  and sloppy which would result in lost sales no doubt.... please find my bug list / feedback below.

Ill continue to give it a thorough test and add any i find. in a hope you can [polish this as its not a great user experience now...

1. client summary on mobile - /whmcs/admin/clientssummary.php?userid=659

a. defaults to input on client drop down, so you have to clse it every time same as on most client profile pages) - see https://www.dropbox.com/s/aja8egumfinfo0z/2021-01-11_15-25-05.png?dl=0


2. View invoice as admin via mobile eg https://www.dropbox.com/s/93suncz40eclqui/2021-01-11_15-26-28.png?dl=0

a. Drop down goes off screen
b. buttons extens out side of box and doesnt look clean
c. sub total overlap on mobile

3. Iphone incompatability with keychain password.

When you go to admin settings area on iphone and it asks for password its incompatbile with using the iphone keychain password as it clashes and keeps suggesting a password rather then using one in keychain - its likely because you are using the button confirm and it thinks it trying to set a password not enter one that exists.


4. Footer in client area - language selector - see https://www.dropbox.com/s/67gf593c65krv2n/2021-01-11_15-31-49.png?dl=0

Uses US flag to denote english (bit odd for the rest of the world to have to select US flag)

5. order front end using twenty - one - Poor alignment of currency selector see https://www.dropbox.com/s/jlkq5e65kmti55m/2021-01-11_15-33-45.png?dl=0

6, poor alignment of additional domain fields labels - see https://www.dropbox.com/s/3up1j3dozreoh97/2021-01-11_15-35-36.png?dl=0

7. poor alugment of already registered button - see https://www.dropbox.com/s/x9sxj6rzi370w62/2021-01-11_15-37-09.png?dl=0

8. broken fields / display of DNS hosting / URL forwarding on domains with it enabled - see https://www.dropbox.com/s/ru77eqj66cbwnbd/2021-01-11_15-41-02.png?dl=0

 

 

 

Share this post


Link to post
Share on other sites

9. using the quick search , any time you click someone from the users section it results in the error - error communicating with server - see screenshot https://www.dropbox.com/s/kubyrxub36k26xz/2021-01-11_22-44-01.png?dl=0

 

choosing anyone from the clients section in the quick search works as does products - so looks specific to the users section in the quick search

Share this post


Link to post
Share on other sites

Hi @tworak,

Thanks for posting this thread and submitting a support ticket. I've addressed the majority of these points in your support ticket. To share a few specific answers which I think could benefit other users:

1. I wasn't able to reproduce this in Chrome or Firefox for Android (screenshot attached). Which browser and device are you using please?

 

4. The display of the US flag for English can be customised to meet your needs by means of a template edit. Specifically to the footer.tpl file and looking at this line:

{if $activeLocale.countryCode === 'GB'}us{else}{$activeLocale.countryCode|lower}{/if}

For more information on customising WHMCS appearance, please refer to https://developers.whmcs.com/themes/

 

5. The arrangement of these dropdown options has been this way for a numbers of years and is currently by design. However you are welcome to customise the appearance of the order form template by editing the /templates/orderforms/$templatename/sidebar-categories-collapsed.tpl template.

The documentation for customising order form templates is located at https://docs.whmcs.com/Order_Form_Templates#Creating_a_Custom_Order_Form_Template

 

8. This is not a stock WHMCS interface. Please contact the vendor of this URL Forwarding page for an update compatible with v8.1.

 

9 & 10. These indicate that your System URL setting is incorrect. Please review this guide to troubleshoot and resolve: https://help.whmcs.com/m/troubleshooting/l/1312423-an-error-occurred-while-communicating-with-the-server-please-try-again

client_summary.jpg

Share this post


Link to post
Share on other sites
Quote

1. I wasn't able to reproduce this in Chrome or Firefox for Android (screenshot attached). Which browser and device are you using please?

In Safari on iphone it tries to auto select it by default causing the dropdown
 

Quote

4. The display of the US flag for English can be customised to meet your needs by means of a template edit. Specifically to the footer.tpl file and looking at this line:

Thanks ill check that -ill have to make a child theme correct?
 

Quote

5. The arrangement of these dropdown options has been this way for a numbers of years and is currently by design. 

Thanks ill check out customising the order form

 

Quote

8. This is not a stock WHMCS interface. Please contact the vendor of this URL Forwarding page for an update compatible with v8.1.

Thanks trying to chase it with Synergy Wholesale but they arent being too helpful

 

Quote

9 & 10. These indicate that your System URL setting is incorrect

you are right! i found the URLS there didnt have https (a relic from times long past - as ive had this WHMCS installed for Many years)

 

 

---

Also thankyou for the ticket response to the other issues identified

One other thing i found after updating to 8.1 my pop cron wasnt working and appeared to have changed address as the suggested one, once i updated pop cron folder location it started working again - its just that during the install etc i wasnt advised this needed changing/ updating so how was i to know

Share this post


Link to post
Share on other sites
15 hours ago, tworak said:

Thanks ill check that -ill have to make a child theme correct?

it surely would be better if the us wasn't hardcoded in the template and some variable used instead - that would be easier to change with a hook rather than creating a child theme.

if the code was as below, then the variable could be manipulated if it's English to be GB, US, AU, NZ or whatever via a hook.

<div class="iti-flag {$activeLocale.countryCode|lower}"></div>

Share this post


Link to post
Share on other sites

Hi @tworak,

18 hours ago, tworak said:

One other thing i found after updating to 8.1 my pop cron wasnt working and appeared to have changed address as the suggested one, once i updated pop cron folder location it started working again - its just that during the install etc i wasnt advised this needed changing/ updating so how was i to know

The /pipe directory has been deprecated for a while. Depending which version you upgraded from/to it was finally removed in v8.0 and the change itemised in the release notes: https://docs.whmcs.com/Version_8.0.0_Release_Notes#Removed_Legacy_Files

Share this post


Link to post
Share on other sites
On 1/12/2021 at 10:53 AM, tworak said:

Thanks trying to chase it with Synergy Wholesale but they arent being too helpful

I believe this has been fixed by Synergy in an update yesterday 🙂

Share this post


Link to post
Share on other sites
17 minutes ago, slim said:

I believe this has been fixed by Synergy in an update yesterday 🙂

yep - can confirm it works.

after a bit of back and forth until i gave evidence their module was over riding the default. To be honest the first few SH reps kept suggesting for to get my developer and that they didn't "use WHMCS"

Annoyingly i spent $$ to bump my ticket to get an "average reply"

At the same time i logged a ticket on their github for the module and their actual dev was super quick to fix FYI their github is @ https://github.com/SynergyWholesale/WHMCS-Domains-Module

Edited by tworak

Share this post


Link to post
Share on other sites

Yeah, if you believe it to be a bug, the quickest way to get it sorted is via github. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated