Jump to content
Sign in to follow this  
xnetco

Not all cards visible on checkout when using Stripe

Recommended Posts

Hello.

We've recently moved to Stripe and it's working very well for existing recurring card payments. However existing store credit cards don't appear on the checkout page. Do you know if it's possible to add them or migrate them all over to Stripe?

Tim 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Rusky
      Apologies for cross posting this from the General Discussion thread. Wasn't sure were best to raise it...
      We recently received a notification from Stripe that an action was required in our Stripe account to lodge a SAQ-D self assessment to remain PCI compliant. This came as a surprise because it was our understanding that WHMCS v8.1 uses Stripe Elements, which supports a simplified PCI compliance. When I questioned Stripe about this I received the following response...
      Can anyone shed more light on the WHMCS PCI compliance situation and if the Stripe gateway in WHMCS really is using Stripe Elements?
      I was basing my understanding on this blog article, however there seems to be a disconnect between this article and what Stripe is saying:
      https://blog.whmcs.com/133563/feature-spotlight-stripe-in-whmcs-78
      Cheers
      John
    • By Rusky
      We recently received a notification from Stripe that an action was required in our Stripe account to lodge a SAQ-D self assessment to remain PCI compliant. This came as a surprise because it was our understanding that WHMCS v8.1 uses Stripe Elements, which supports a simplified PCI compliance. When I questioned Stripe about this I received the following response...
      Can anyone shed more light on the WHMCS PCI compliance situation and if the Stripe gateway in WHMCS really is using Stripe Elements?
      I was basing my understanding on this blog article, however there seems to be a disconnect between this article and what Stripe is saying:
      https://blog.whmcs.com/133563/feature-spotlight-stripe-in-whmcs-78
      Cheers
      John
    • By henrimule
      I have had stripe for a while without issues until I upgraded WHMCS  yesterday to v8 and a few hours after a customer complaint we were charging his card for invoices he doesn't wanna pay. I checked his account and noticed he has been charged for unpaid invoices due 2017 to present. I had a test account in WHMCS that I used to validate the system, in there I had various invoices I have created, some to a tune of $900. Today when I checked my card I have been charged for all the unpaid invoices in my test account and every bit of them paid.
      Other customers have been charged as well and all unpaid invoices in their account no matter how old have been paid. The frustration led me to deactivate Stripe all together as I was not sure what was going on and didn't wanna deal with any of these. I had to refund all the money back to the customers and myself. I called STRIPE and they said, this isn't their fault but my 3rd-party application is the problem and in this case WHMCS.
      What is going on? Why are all unpaid invoices being charged automatically without approval when we do not have any settings to that effect? 
    • By thatlinuxguy
      My business is in the US. 
      Our newly acquired book keeper noticed that while WHMCS is documenting tax payments, the information being sent to Stripe does not. 

      After contacting Stripe support they mentioned that the 3rd party app ( WHMCS) needs to add a specific metadata component to be able to pass that tax over to Stripe. 

      *** Note: Stripe is to not deduct taxes only categorize the tax for bookkeeping purposes

      These are the articles they sent me. 
      https://stripe.com/blog/adding-context-with-metadata
      and
      "
      When you create a charge with the Stripe API, you (or a third-party platform, if you're using one) send the total amount to Stripe, without any qualifiers about what elements went into making up that final amount --for example, a sales tax amount, or shipping fee.
      If you want to break out parts of that final amount, you'll need to explicitly tell Stripe that. Otherwise we just see a total `amount`, and have no way of knowing what portion of that is tax.
      The easiest way to do this is with the metadata parameter on a charge, with which you can add any arbitrary information as a series of key:value pairs, which will be surfaced to you in our standard exports via the dashboard. You can also pull this data from Sigma the API [1][2].
      You can read about metadata here:
      https://stripe.com/blog/adding-context-with-metadata
      If you're already putting these amounts in the metadata parameter, you should see this in your exports.
      If you're using a third-party product or platform to create your charges with Stripe and they are putting this clarifying information about your charges in metadata, you should see it in your Stripe reporting. If you do not, it means they are not sending us this information. You should reach out to them to ask about this if this is something you need. 
      Alternatively, it is possible that the platform offers its own reporting on which these amounts are broken out, even if they're not sending this information to Stripe.
      [1] https://stripe.com/docs/sigma
      [2] https://stripe.com/docs/api
      "
       
      Any ideas would be much appreciated.
      TIA!
    • By ShaneP
      Hi All 
      I tried to purchase a hosting package on mt whmcs and when i click the checkout button after filling out my details this error comes up. I have also checked with my payment gateway provider and they say it is whmcs problem. The site which i am referring to is https://skyehost.co.za/client/ I have also attached the error message below.
       
      If the community could be so kind to help me with this problem.
      Thanks
      Shane

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated