Jump to content
jimsweb

Resellerclub original cost missing

Recommended Posts

After upgrading to V8.0 and V8.0.1, I just noticed that the reseller club domain name prices are no longer displaying.. is there anyone else seeing this issue?  if so how can we get this corrected? any help/comments highly appreciated. 

 

Untitled.thumb.png.fbf32352d0eb5c11ec04a1592ea5d32b.png

 

 

Edited by jimsweb

Share this post


Link to post
Share on other sites

Hi @jimsweb

I can't reproduce this behaviour here.

If it's still occurring, can you please share the currency of your ResellerClub account and the currencies in WHMCS?

Share this post


Link to post
Share on other sites

Edit the ResellerClub connection data again, specifically the API value
I have noticed that WHMCS8, alters the API values of ResellClub and Stargate

Share this post


Link to post
Share on other sites

@jlucho  unfortunately it dint work. I also tried to reimport and it messed up everything. Both selling pricing and original price became zero after re-import.. !!!  too annoying..

Share this post


Link to post
Share on other sites

Hi @jimsweb,

In order to see the commands being sent/received between WHMCS and the module, the Utilities > Logs > Module debug Log tool can be used
Please enable it, reproduce the problem, disable it again and then copy the data here for us to review.

More detailed instructions are published at http://docs.whmcs.com/Troubleshooting_Module_Problems

Share this post


Link to post
Share on other sites

@WHMCS John

thank you. I enable module debug log and this is what came up in the logs that appear to be an error.   The response seems saying 'general price not set'. This doesn't seem to be correct from resellerclub's perspective. I have verified it multiple times and all proces are set up over there. How do i fix this? any clues? 

 

products/reseller-cost-price

Array
(
    [auth-userid] => xxxx
    [api-key] => xxxx
    [url] => https://httpapi.com/api/products/reseller-cost-price.json?auth-userid=xxx&api-key=xxx
)


Array
(
    [status] => ERROR
    [message] => General price not set
)

 

Edited by jimsweb

Share this post


Link to post
Share on other sites

Hi @jimsweb,

Unfortunately ResellerClub's developer documentation doesn't seem to provide any information on the error "general price not set", so I can't speculate on what the cause might be.

Please contact ResellerClub support and provide that API data to them for review. Do not mention WHMCS in your message to ResellerClub support.

 

Share this post


Link to post
Share on other sites

I had the same error in 7.10.2 a few weeks ago, ticket from reseller club said the WHMCS api call was wrong. I raised ticket RUC-501997 with WHMCS but no fix was done. 

Share this post


Link to post
Share on other sites

thanks John.

I contacted reseller club and they were able to fix it for me.  per them - 

 

"The issue was on account of a few products that were discontinued. We have fixed this and you should be able to successfully retrieve the pricing "

Share this post


Link to post
Share on other sites
On 10/10/2020 at 8:31 AM, jimsweb said:

thanks John.

I contacted reseller club and they were able to fix it for me.  per them - 

 

"The issue was on account of a few products that were discontinued. We have fixed this and you should be able to successfully retrieve the pricing "

 

Hi friend, i have same issue as well, now trying to fix it, could you please guide me how you manage to fix the issue? btw is it now really fixed?  or maybe how did you contacted reseller club? as i tried  to contact them but they are sending me back to whmcs support. thank you

Share this post


Link to post
Share on other sites

@Richardmax,

My recommendation would be to use the Module Debug Log to capture the API error details during the TLD Pricing Import process.

Then open a new support request with ResellerClub providing that API request and response data to them for review at their end.

Do not mention WHMCS in your message to ResellerClub support.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated