Jump to content
giora

Missing the Waiting Tickets, Unpaid invoices and Orders on top

Recommended Posts

Hello
I am missing the Waiting Tickets, Unpaid invoices and Orders on top, It was very useful and I have to take extra steps now.

😞

Giora

Share this post


Link to post
Share on other sites

Hi @giora,

These statistics are not part of the new look admin theme, but the variables are still available so could be added by way of a custom theme.

Information on this doing this is discussed here:

 

Share this post


Link to post
Share on other sites

This was the most useful information shown on the admin dashboard. Unbelievable that such critical information has been removed.

Share this post


Link to post
Share on other sites
13 hours ago, glenn said:

This was the most useful information shown on the admin dashboard. Unbelievable that such critical information has been removed.

This is correct.

 

@WHMCS John Would request to add this section in some form, perhaps as notification icons or dropdowns if space is an issue ?

Share this post


Link to post
Share on other sites
16 hours ago, glenn said:

This was the most useful information shown on the admin dashboard. Unbelievable that such critical information has been removed.

  Agree also! Definitely one of the most looked at parts of my WHMCS. Unless you are on the Dashboard (which we are usually not) there is now no way to see if there has been a ticket reply or if an order needs to be processed 😕

I'd like to see a notification of some sort for both in the header and the sidebar in the next release asap. 

Share this post


Link to post
Share on other sites

it is possible to add the details back with a hook (i'm still tidying up the CSS and testing on other devices)...

PtNnZ0o.png

it's probably also worth mentioning that from my limited texting of the GA so far, the blend theme from v7.10.2 still appears to work on v8 - if you still want to use the old layout in the short-term....

if updating to v8 and wanting to use the old theme, then uploading the old blend folder from a v7.10.2 download to the /admin/templates folder, e.g call it blend7 (don't overwrite the existing v8 blend theme as those changes would get overwritten during an update) - then you can switch themes in the "My Account" section.

from a quick test, there is a missing language string in the help menu, and the setup title as been changed - but if you correct those with Admin Language Overrides, then it looks like this...

s0cf6FQ.png

<?php
$_ADMINLANG['setup']['title'] = "Setup";
$_ADMINLANG['help']['support'] = "Get Help";

Mass Mail is called Email Campaigns now, but the URL hasn't changed... intellisearch still works... some of the sidebar icons might be missing, but I suspect that's caused more by the v8 dev being a fresh install rather than an updated v7 with previously existing v7 image files.

i'm still working on other solutions to fix the hideous v8 menu system...

Share this post


Link to post
Share on other sites
Posted (edited)

If history is any judge, some time soon someone from WHMCS will pop in here to say to add it as a feature request in that system. 
I'm curious why this was never spotted or discussed in the BETA testing so they might keep it in place rather than removing such a useful thing.

Quote

i'm still working on other solutions to fix the hideous v8 menu system...

Oh, did that also suffer some changes no one asked for?

Edited by bear

Share this post


Link to post
Share on other sites

It feels like when MS removed start menu on Windows. Anyway I was also trying to add the details back. I was thinking about something like this. Basically if there's at least one pending item the ⚠️ appears. It expands on mouse-hover to display more information. The boring part is that I need to count pending invoices, orders and tickets as "the variables are still available"... that's scary.

nicer-maybe.png.3ddf4765172a4d44f94b64bf4fa22944.png

Share this post


Link to post
Share on other sites
On 10/1/2020 at 2:05 PM, bear said:

I'm curious why this was never spotted or discussed in the BETA testing so they might keep it in place rather than removing such a useful thing.

 

It was... during the beta and RC period we had a similar thread with the same complains.  

Share this post


Link to post
Share on other sites
Just now, ramf said:

It was... during the beta and RC period we had a similar thread with the same complains.  

methinks he was being sarcastic - as the three of us all posted in that now-deleted (sorry hidden!) thread... which, for the benefit of others, is worth mentioning that it was started at the beginning of August (2 months ago)...

Share this post


Link to post
Share on other sites
2 minutes ago, brian! said:

methinks he was being sarcastic - as the three of us all posted in that now-deleted (sorry hidden!) thread... which, for the benefit of others, is worth mentioning that it was started at the beginning of August (2 months ago)...

🙂
 

Share this post


Link to post
Share on other sites
17 hours ago, Kian said:

It feels like when MS removed start menu on Windows.

was it a v6 release where without warning they removed domain pricing from the domain registration pages - only for it to be brought back a year later ??

17 hours ago, Kian said:

Anyway I was also trying to add the details back. I was thinking about something like this.

I had a similar thought - simple enough coding, just time consuming... if you ever post it, you might want to mention it in the thread below as there are similar complaints about the missing stats in there too.

Share this post


Link to post
Share on other sites
On 10/1/2020 at 5:05 PM, bear said:

I'm curious why this was never spotted or discussed in the BETA testing so they might keep it in place rather than removing such a useful thing.

Yet I thought the GA was the beta. Poor me.

Share this post


Link to post
Share on other sites
42 minutes ago, Mechanic said:

Yet I thought the GA was the beta. Poor me.

there were 5 public betas and 2 months of testing before what you're seeing now.

Share this post


Link to post
Share on other sites
On 9/30/2020 at 9:18 AM, giora said:

Hello
I am missing the Waiting Tickets, Unpaid invoices and Orders on top, It was very useful and I have to take extra steps now.

😞

Giora

I am also sad to see this has been removed - so have to spend even more time implementing customisation to fix what wasn't broken.

Another example of WHMCS team not bothering to listen to users - and simply doing what they want instead...... 

 

Share this post


Link to post
Share on other sites
8 minutes ago, sol2010 said:

Another example of WHMCS team not bothering to listen to users - and simply doing what they want instead...... 

That true it like they dont listen to they clients.

Share this post


Link to post
Share on other sites
16 hours ago, brian! said:

there were 5 public betas and 2 months of testing before what you're seeing now.

2 months of testing isn't really sufficient to produce a stable version. They should really focus more on stability rather than feature upgrades that nobody needs.

Perhaps feature upgrades every year and only security updates every month?

Share this post


Link to post
Share on other sites

 i've posted the hook for the admin info bar in the thread below - should work on both v8.0.0 and v8.0.1 🙂

Share this post


Link to post
Share on other sites

The Ticket and Order count in the header on every page was a huge help to notice when new tickets come in and to keep track of statuses, etc. But when I add this code in to either nav.tpl or header.tpl I get the links but no number, there's nothing displayed at all. I can't seem to find any documentation on what the correct variable is to pull the number in. Someone who knows Blend please help!

    <div class="header">
        <div class="logo">
            <a href="index.php"><img src="templates/{$template}/images/logo.gif" border="0" /></a>
        </div>
        <div class="stats">
            <a href="orders.php?status=Pending">
                <span class="stat">{$sidebarstats.orders.pending}</span>
                {$_ADMINLANG.stats.pendingorders}
            </a> |
            <a href="invoices.php?status=Overdue">
                <span class="stat">{$sidebarstats.invoices.overdue}</span>
                {$_ADMINLANG.stats.overdueinvoices}
            </a> |
            <a href="supporttickets.php">
                <span class="stat">{$sidebarstats.tickets.awaitingreply}</span>
                {$_ADMINLANG.stats.ticketsawaitingreply}
            </a>
        </div>
    </div>

Share this post


Link to post
Share on other sites

Just updated to WHMCS 8 this week and already regretting it. 

Couple of things adding time to tickets and past due invoices

  1. When you removed the Tickets link, we had it set to take us with 1 click to all open tickets. Now we have to mouse move and then click.
  2. When your viewing or acting on a ticket, you now have to do step one above to get back all your open tickets. Big time burner!
  3. With 7 and previous, the admin menu bar had a link to all past due invoices, it's gone so we don't see a count of past due/unpaid invoices. We have to click around in Billing -> Invoices -> Past Due.

I know this sounds like nit-picking but, this has added time to our workflow on ticket responses and past due billing research. PLEASE add those back!

Share this post


Link to post
Share on other sites
4 minutes ago, webjive said:

With 7 and previous, the admin menu bar had a link to all past due invoices, it's gone so we don't see a count of past due/unpaid invoices. We have to click around in Billing -> Invoices -> Past Due.

 

Share this post


Link to post
Share on other sites

This is what I'm referring to.  The last pic is V7. The admin header links were way quicker to use

Screen Shot 2020-10-06 at 10.37.18 AM.jpg

Screen Shot 2020-10-06 at 10.37.04 AM.jpg

Admin_dashboard.png

Share this post


Link to post
Share on other sites

in the short-term, there's nothing to stop you getting the blend theme from v7.10.2, renaming it and uploading it to the v8 admin/templates folder... it would need a couple of changes, but it would still work (as far I could tell from a quick test).

.. and yes, the v8 menu system is awful.

Share this post


Link to post
Share on other sites
On 10/3/2020 at 10:00 PM, brian! said:

i've posted the hook for the admin info bar in the thread below - should work on both v8.0.0 and v8.0.1 🙂

You certainly deserve some praise. Whenever someone needs any help, you are right at it!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated