Jump to content
Sign in to follow this  
jeebee123

Domain search not accurate

Recommended Posts

Hi,

I'm using WHMCS but the domain search results are very bad.

What could be the problem? I can't find anything strange in the log files.


The problem is that most of the time it says: "The charachters do not match" (Google ReCaptcha problem?) or it says that the domain isn't available while it stil is (see attachments).

 

Does it have something to do with a lookup provider?

 

Cheers.

screeen01.png

Screenshot_3.png

Screenshot_4.png

Share this post


Link to post
Share on other sites
4 minutes ago, jeebee123 said:

Does it have something to do with a lookup provider?

if your lookup provider doesn't sell .nl domains, then WHMCS will probably resort to using whois lookups - and for .nl, I think there is still a 15 search limit per day on port 43.... 500 per day if you use the website...

Share this post


Link to post
Share on other sites
13 minutes ago, jeebee123 said:

The problem is that most of the time it says: "The characters do not match" (Google ReCaptcha problem?)

does the same thing still occur with the Six template? what happens if you turn off Recaptcha ??

Share this post


Link to post
Share on other sites
23 minutes ago, brian! said:

does the same thing still occur with the Six template? what happens if you turn off Recaptcha ??

Hmm strange. When Recaptcha is off the charachter problem is solved. I think there goes something wrong.

I disabled it for the domain checker.

 

29 minutes ago, brian! said:

if your lookup provider doesn't sell .nl domains, then WHMCS will probably resort to using whois lookups - and for .nl, I think there is still a 15 search limit per day on port 43.... 500 per day if you use the website...

That could be the problem. Is there a way to change the server? I can't find the includes/whoisserver.php anymore.

Share this post


Link to post
Share on other sites
1 minute ago, jeebee123 said:

Hmm strange. When Recaptcha is off the character problem is solved. I think there goes something wrong.

that could be an issue with the custom template - with recaptcha on, it should work with Six & standard cart - disabling it in domainchecker will remove the issue though!

3 minutes ago, jeebee123 said:

That could be the problem. Is there a way to change the server? I can't find the includes/whoisserver.php anymore.

it was moved a few years back - custom whois entries would now be put in /resources/domains/whois.json - and the format is slightly different too.

https://docs.whmcs.com/WHOIS_Servers

Share this post


Link to post
Share on other sites

Thanks guys for the help. I've creeated a whois.json file with custom WHOIS servers and now everything is working like a charm.


Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Hosting!
      Successfully connected Enom domain provider and WHMCS and activated but it does not seem to be working. What could be the reason for this and how can this problem be solved?

    • By andyhughes73
      I have bought a domain on behalf of a customer, through my hosting provider. I would like to attribute this domain to my customer's WHMCS account for invoicing and renewal purposes but I'm not entirely sure how. The WHMCS system is also hosted on the same hosting provider. Not sure that's relevant, probably not.
      I have done a search to see if there are other posts but I've drawn a blank and I can't find it in the manual, or maybe I'm misunderstanding how to explain it.
      Any help would be much appreciated.
       
    • By FrenchMarie
      Good morning all,

      I come to you today because I want to have the categories and domain extensions on a personalized page.

      I took the elements of the domainregister.tpl file, but unable to load the list of domain categories and the list of extensions.

      A big thank you to you in advance for any response that may put us on the path
    • By immu
      Hey Team,
      I have a custom form where user inputs his domain name and tld, post submit - I want to catch the query string parameters, execute search (for availability) and show results accordingly.
      in WHMCS I see lot of 'clientareadomain...' tpl templates, I'm not sure which tpl points to ' register new domain page' in client area.
      can you guys help me here, really stuck
       
      Thanks in Advance.
      Best Regards,
      Immu
    • By sly2000
      Colleagues, in general, the question is this: buying domains does not work (neither automatic nor manual) (WHMCS version - 7.10.1)
      In the logs he writes the following:
      23/09/2020 22:17 Domain Registration Failed - Domain ID: 8 - Domain: primer-dom.com - Error: Operation can not completed successfully!<br />Reseller not found! Although the reseller is clearly indicated in the settings! If you change the reseller (domain registrar) to any other, the effect is the same ...
      Any thoughts on this? What could be the problem?

       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated