Jump to content
ejmerkel

Cron PHP Version Mismatch

Recommended Posts

Posted (edited)

I just switched my WHMCS installation to PHP 7.3 via the cPanel multi-php manager. Under the health section of WHMCS I get the following warning:

Quote

Your environment appears to be running a different PHP version (7.2.30) for the System Cron than the currently loaded PHP version (7.3.17). This may cause issues running your System Cron.

However,  it also says I am running PHP 7.3

 
Quote

 

PHP Version

Your PHP version 7.3.17 is supported by WHMCS.

Your PHP version is actively supported by PHP for both bug fix and security releases.

 

 

My cron jobs all match the automation PHP setting as "/opt/cpanel/ea-php73/root/usr/bin/php -q" and it looks like it is loading the correct php.ini

Quote

/opt/cpanel/ea-php73/root/usr/bin/php -i | grep "Loaded"
Loaded Configuration File => /opt/cpanel/ea-php73/root/etc/php.ini

Also, I have no php.ini's in the public_html of the WHMCS site so it is using the default multiphp ini for 7.3 so I am a little puzzled on how or where to fix this?

Best regards,

Eric

Edited by ejmerkel

Share this post


Link to post
Share on other sites

Hello @ejmerkel,

Thank you for your post.

10 hours ago, ejmerkel said:

I just switched my WHMCS installation to PHP 7.3 via the cPanel multi-php manager. Under the health section of WHMCS I get the following warning:

Quote

Your environment appears to be running a different PHP version (7.2.30) for the System Cron than the currently loaded PHP version (7.3.17). This may cause issues running your System Cron.

However,  it also says I am running PHP 7.3

What this indicates, is while your local account is running on PHP 7.3.17, the cron is using PHP 7.2.30, usually, this can be resolved by updating your cron line, in cPanel this would usually involve replacing php -q with the /path/to/php7.3 -q your hosting provider should be able to confirm the PHP 7.3 Path.  

11 hours ago, ejmerkel said:

My cron jobs all match the automation PHP setting as "/opt/cpanel/ea-php73/root/usr/bin/php -q" and it looks like it is loading the correct php.ini

 

If your cron in cPanel is set to /opt/cpanel/ea-php73/root/usr/bin/php -q then this could be a false positive and should be safe to ignore at the moment you should see the error disappear soon, is the cron running?

 

Share this post


Link to post
Share on other sites

I assumed the Health Check was real time but I checked again today after the daily cron ran on 7.3 and the warning is now gone so I guess it was a false alarm. 😏

Best regards,

Eric

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated