Jump to content
Ross_Iced

Cron Suddenly Stopped Working

Recommended Posts

Hello,

About two days ago I have noticed that my daily cron has stopped working. Usually I get an email at 9:00am sharp with a cron report, and it was 9:03 and I have not received the email. I then login to WHMCS admin side, and notice that in the logs it it just showed "Automated Task: Starting Cancellation Requests". After this - no further entires existed. I then manually ran the crontab with the -force and -vvv, and everything completed successfully and was logged appropriate - both the cron report and domain sync emails were sent.

Four hours later (i have domain syncs set to happen every 4 hours) no domain syncs are occuring. I then check the logs, and tasks are just not running by themselves. The only way I can get cron to run is to force run it manually. Upon checking the status and invocation of cron, it shows it in green that it is successful, and it says "Last cron run 5 minutes ago" and everything seems normal.

I have no idea why the automation just suddenly stopped. Could anyone assist me with how to troubleshoot this? 

Yes - I've already done all basic troubleshooting steps as displayed in the cron troubleshooting documentation.

Share this post


Link to post
Share on other sites

Hi,

Have you found a solution to this?

I am sitting with the same issue after an upgrade to 7.10.2.  I receive no emails but yet WHMCS reports cron is operating correctly. 

If I force the cron, the emails do arrive. According to WHMCS support, this indicates that I have disabled System Emails for my user but I have double check and even looked around in the DB but everything is enabled.

I have read everything I can find on whmcs.com. No luck.

If I add -vvv to the command in the crontab I can see it runs and completes from the cron output emails I receive, which is also confirmed by the Activity Log.

I am suppose to receive my Daily Cron email once a day and my Domain and Transfer Sync emails each hour, but nothing.

Any suggestions?

Share this post


Link to post
Share on other sites

Check your activity log for daily cron.

Maybe it's running fine and there's just a problem with whe email being sent

Share this post


Link to post
Share on other sites

Thank you for the suggestion.

I have made sure that the emails are fully functional and are being sent from the server.

That is not the cause of the problem.

Share this post


Link to post
Share on other sites
Posted (edited)

Anyway, can you see if daily cron appear in the activity log?

Next step should be looking in the cron log

Edited by egrueda

Share this post


Link to post
Share on other sites

 The daily cron entries do appear in the Activity Log and the the daily cron completes. All of this is also verified in the cron log file.

Share this post


Link to post
Share on other sites

Fine! next thingk I would try is enabling PHP error logging and wait for the next daily run

Maybe there's a provisioning module returning an error so the daily cron stops in the iddle of the run

Share this post


Link to post
Share on other sites

Sorry, I thought I was talking to the original OP, but seems you've hijacked his post with another issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated