Jump to content
Sign in to follow this  
SwiftModders

Email marketer sends mail everyday

Recommended Posts

Has anyone else noticed that after the WHMCS 7.10 update that the Email Market no longer functions as expected? I woke up to some upset clients who received the same emails (after a 24-hour period) that should only be sent once. Does anyone else have a similar issue?

Share this post


Link to post
Share on other sites

Hi,

I setup an email marketer to send a mail after 5 days to a customer that has active products.
The only problem is... it sends the same mail every day...

What did i do wrong?

Schermafbeelding 2020-04-15 om 20.15.22.png

Share this post


Link to post
Share on other sites

Seems to be other with this issue also: 

However, I've just discovered that the email template selection (last field on the Email Marketer form) is broken, no matter what I select, when I save and go back in, it resets to the first option.

Are you getting this issue too?

Share this post


Link to post
Share on other sites
On 4/11/2020 at 8:29 AM, SwiftModders LLC said:

Has anyone else noticed that after the WHMCS 7.10 update that the Email Market no longer functions as expected? I woke up to some upset clients who received the same emails (after a 24-hour period) that should only be sent once. Does anyone else have a similar issue?

Yes, I'm having the same problem. I have a client who has received a New Account Information email from the Email Marketer 3 days in a row. The weird thing is I don't have an email with that title set up in the email marketer.

Share this post


Link to post
Share on other sites

I'm having the same problem. There is another thread about this issue too.

This one may require a support ticket. Let us know if anyone finds a resolution or knows how to fix this.

Share this post


Link to post
Share on other sites
10 hours ago, gbotica said:

Seems to be other with this issue also: 

However, I've just discovered that the email template selection (last field on the Email Marketer form) is broken, no matter what I select, when I save and go back in, it resets to the first option.

Are you getting this issue too?

Yes, I reported the issue to WHMCS and they have made a case for it to be fixed. The emailing everyday issue for me seems to stem from an older cron folder. I had to manually update it as it was misconfigured. Still the email marketer does not function the way it should.

 

2 hours ago, markp said:

Yes, I'm having the same problem. I have a client who has received a New Account Information email from the Email Marketer 3 days in a row. The weird thing is I don't have an email with that title set up in the email marketer.

This is probably related to what gbotica said above. Your template field is reset every time you edit it. So it's possible you edited the rule and the template selected something else.

Share this post


Link to post
Share on other sites
3 hours ago, SwiftModders LLC said:

Yes, I reported the issue to WHMCS and they have made a case for it to be fixed. The emailing everyday issue for me seems to stem from an older cron folder. I had to manually update it as it was misconfigured. Still the email marketer does not function the way it should.

 

This is probably related to what gbotica said above. Your template field is reset every time you edit it. So it's possible you edited the rule and the template selected something else.

Did they send you something to fix the issue?

Share this post


Link to post
Share on other sites

If an update can cause issue like this, would be helpful WHMCS in future create a checkbox to disable all email marketer, so We can ensure we reduce risk during first days of using new version WHMCS before issues like this get discovered...Clients receives a lot of emails not wanted is no good. and it also could cause Microsoft flag our IP to less trust which can make our future emails to junk.

Share this post


Link to post
Share on other sites
14 hours ago, zitu4life said:

If an update can cause issue like this, would be helpful WHMCS in future create a checkbox to disable all email marketer

you can prevent the marketer from sending emails by skipping the EmailMarketer task in your cron job...

https://docs.whmcs.com/Crons#Tasks

if Swift says there's a case number, there's still no knowing when the fix might be released - I had assumed there wouldn't be another maintenance update for a couple of months...

Share this post


Link to post
Share on other sites
3 hours ago, gbotica said:

You can also just disable each email marketer rule individually, in the set up page for the Rule.

Unfortunately, that is what I've done. I just started using the email marketer, so I only have one rule so far, but it was the beginning of an effort to use the tool for a more robust campaign. I'll have to look at a different option.

Share this post


Link to post
Share on other sites

 Hi there,

I'm pleased to advise you that we have an immediate fix available for that particular issue. For reference we’ve assigned this particular issue within WHMCS a case number, CORE-14565.

The hotfix is available for download from:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated