Jump to content
Gricenko Mihail

Strange behaviour when adding product to cart

Recommended Posts

Hello, i have found very strange behaviour when adding product to cart.

I have WHMCS 8.3 with standard cart and template six, all additional modules are disabled.

I have product of type "shared hosting" configured with "One Time/Monthly" only price (it's important).

When following link to this product: /cart.php?a=add&pid=106 i was redirected directly to /cart.php?a=view page with one product shown in the list. It's normal behaviour for this process.

But from time to times i have another behaviour... when i following link /cart.php?a=add&pid=106 (cart has been previously emptied) i was redirected to page /cart.php?a=view and i have TWO of products added in the list.. 

So i doing next steps: Empty Cart -> Follow the /cart.php?a=add&pid=106 link and get two products in the cart... what's going on? 

Share this post


Link to post
Share on other sites
1 minute ago, Gricenko Mihail said:

I have product of type "shared hosting" configured with "One Time/Monthly" only price (it's important).

Why it's important? if i configure product with, for example One Time/Monthly and Quarterly pricing option then after following /cart.php?a=add&pid=106 link i was redirected to page /cart.php?a=confproduct&i=1 first to choose billing cycle and after that to /cart.php?a=view with only one product added as expected...

Share this post


Link to post
Share on other sites

Hello @Gricenko Mihail

Thank you for your post I tried to click your link however it seems you do not seem to have a product with the ID of 106 setup, if you do the same with another product e.g 87 you will find you are directed to the cart to select a billing cycle, if you are finding this is not happening please provide us with the exact link to the product so we can review it.

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/20/2020 at 2:59 AM, WHMCS ChrisD said:

Hello @Gricenko Mihail

Thank you for your post I tried to click your link however it seems you do not seem to have a product with the ID of 106 setup, if you do the same with another product e.g 87 you will find you are directed to the cart to select a billing cycle, if you are finding this is not happening please provide us with the exact link to the product so we can review it.

 

It's very simple to reproduce, i just setup test environment:

https://stage.wpcomplex.com/cart.php?a=add&pid=1

It's fresh installation of WHMCS 7.8.3 with only one product added, type of product Shared hosting, and one One Time/Monthly price configuration.

You can simply navigate several times to link provided above and see the issue described in original post.

I have recorded short video with demonstration: 

 

Edited by Gricenko Mihail

Share this post


Link to post
Share on other sites

when I test the link, it is only adding one product to the cart each time... if I empty the cart and then click the link again, it's still only adding one product to the cart.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated