Jump to content

Recommended Posts

I'm currently using Paypal Basic and therefore trying to enable the new Paypal module (as I don't need subscriptions), but each time I try to link my account - I am able to login my paypal account and accept all prompts which then gives me a "Thanks for signing up. You now have an account and you've successfully integrated PayPal with WHMCS." message, but that's it - my account doesn't seem to link to my WHMCS.

Any thoughts?

Share this post


Link to post
Share on other sites

Hello @equiphase

Thanks for your post!

If you are able to complete the linking process using the Link to PayPal button under Setup > Payments > Payment Gateways after activating the module, but the details aren't filled in automatically, this would suggest that the server has cross-site access disabled and the required PayPal assets are failing to load.

This will need to be addressed by your system administrator to allow the requests to be successful.

I also understand using Mozilla FireFox is a workaround that can address this.

Share this post


Link to post
Share on other sites

ChrisD, perhaps you can give more information on exactly what is required as I have the same issue.

And do you mean "using FireFox can address this..." or "using FireFox can cause this..." as your statement doesn't make sense.

Share this post


Link to post
Share on other sites

I have tried Firefox, Edge, Chrome, Safari and Opera - I have even tried my mobile browsers as well to get Paypal to link ... and whatever I do, all I get is a " Thanks for signing up. You now have an account and you've successfully integrated PayPal with WHMCS. " message and no link!

PS I'm running PHP 7.3

Edited by equiphase

Share this post


Link to post
Share on other sites

Hi all,

Can you confirm if the Client Secret and Client ID are filled in automatically under the "Manage Existing Gateways" tab for the PayPal gateway?

If not, then please open your browser's Network Analyser and click the Link PayPal Account button

Follow the process through in the popup, and at the end inspect the request from signup.js back in the main window.

Are you seeing an error like:

signup.js:1 Uncaught DOMException: Blocked a frame with origin "https://example.com" from accessing a cross-origin frame.

If so, please temporarily disable this setting  in your browser config:

https://stackoverflow.com/questions/3102819/disable-same-origin-policy-in-chrome

https://stackoverflow.com/questions/17088609/disable-firefox-same-origin-policy

https://stackoverflow.com/questions/4556429/disabling-same-origin-policy-in-safari

Then try again. Please let me know if the error still occurs.

Share this post


Link to post
Share on other sites

Hi John,

I've just followed this in the Network window of the Firefox Developer Tools - it's produced no errors and from what I can see, it completed correctly, but still no Client ID or Client Secret filled in!

Edited by equiphase

Share this post


Link to post
Share on other sites

Has anyone had any further luck with the new PayPal Module?

I upgraded to 7.9.1 from 7.8 today, and I am experiencing the same issue.

When clicking on 'Link PayPal Account' for the new module, PayPal is opened in a new tab and once finished I am left with the 'Thanks for signing up' message and nothing else. The previous tab has WHMCS open and does not refresh.

I have tried the same process on Chrome and Safari, and both have the same result.

In Chrome, I have tried to temporarily disable the cross browsing setting and still no joy. 😞 

Share this post


Link to post
Share on other sites
5 hours ago, WeaveHosting said:

Has anyone had any further luck with the new PayPal Module?

I upgraded to 7.9.1 from 7.8 today, and I am experiencing the same issue.

When clicking on 'Link PayPal Account' for the new module, PayPal is opened in a new tab and once finished I am left with the 'Thanks for signing up' message and nothing else. The previous tab has WHMCS open and does not refresh.

I have tried the same process on Chrome and Safari, and both have the same result.

In Chrome, I have tried to temporarily disable the cross browsing setting and still no joy. 😞 

@WeaveHosting could you please try using FireFox and see if this helps, if you could also try the Network  Analyser and let me know any errors that pop up so we can troubleshoot further,

Share this post


Link to post
Share on other sites
5 hours ago, WeaveHosting said:

Has anyone had any further luck with the new PayPal Module?

I upgraded to 7.9.1 from 7.8 today, and I am experiencing the same issue.

When clicking on 'Link PayPal Account' for the new module, PayPal is opened in a new tab and once finished I am left with the 'Thanks for signing up' message and nothing else. The previous tab has WHMCS open and does not refresh.

I have tried the same process on Chrome and Safari, and both have the same result.

In Chrome, I have tried to temporarily disable the cross browsing setting and still no joy. 😞 

Yep, same. 

I was advised that the same-origin header had to be blocked on the server.  I did this and I still can't get it to work.  WHMCS seriously need to look at how this is implemented...but based on my experience with them, it is unlikely that they will do anything about it.

Share this post


Link to post
Share on other sites
1 hour ago, 123host said:

Yep, same. 

I was advised that the same-origin header had to be blocked on the server.  I did this and I still can't get it to work.  WHMCS seriously need to look at how this is implemented...but based on my experience with them, it is unlikely that they will do anything about it.

@123host Are you seeing any details in the Network Analyser of your Browser Console?  Did you try using Mozilla FireFox as well?

Share this post


Link to post
Share on other sites

Yes I am using FireFox.  However the same thing happens in Chrome.

I see no errors in the network analyser.  What should I be looking for?

Share this post


Link to post
Share on other sites
12 hours ago, WHMCS ChrisD said:

@WeaveHosting could you please try using FireFox and see if this helps, if you could also try the Network  Analyser and let me know any errors that pop up so we can troubleshoot further,

Hi @WHMCS ChrisD,

I have also tried in Firefox and still the same issue. Attached is the result of the Network tab.

paypal-network-tab.png

Share this post


Link to post
Share on other sites

Still having issues with adding the new PayPal module. Is there likely to be a fix released? I don't appear to be the only person struggling.

Share this post


Link to post
Share on other sites

Hi there,

We haven't been able to reproduce this problem on any of our test environments or installations yet.

It would be most helpful if you could open a support ticket with login details so we can inspect exactly what's going in for ourselves: https://www.whmcs.com/submit-a-ticket/

Share this post


Link to post
Share on other sites
On 2/7/2020 at 3:05 AM, WHMCS John said:

Hi there,

We haven't been able to reproduce this problem on any of our test environments or installations yet.

It would be most helpful if you could open a support ticket with login details so we can inspect exactly what's going in for ourselves: https://www.whmcs.com/submit-a-ticket/

Ticket #GTA-364129

Share this post


Link to post
Share on other sites

@123host,

Your ticket was auto-closed whilst we were waiting to hear back from you at the start of the month.

Can you please reply to your ticket to re-open it and add your current WHMCS admin and SFTP credentials so we can investigate?

Share this post


Link to post
Share on other sites

I also have the same problem, exactly. Tried with Firefox AND Safari too. Same results. 

The workaround suggested is not working since F12 on a Mac pumps the volume of the computer up.

Edited by krokos

Share this post


Link to post
Share on other sites

This is all a figment of our imaginations.  WHMCS is adamant there isn't a problem. 😕

Share this post


Link to post
Share on other sites

I have opened a ticket regarding this and I got the same answer as here although I have given the credentials so the WHMCS staff can give it a try themselves. They didn't even try, they just gave me the same answer about Firefox and cross-site access.

I have already added the following code in my .htaccess file to enable CORS but it is still not working.

<IfModule mod_headers.c>  
    Header set Access-Control-Allow-Origin '*'
</IfModule>

This is definitely an issue and needs to be resolved ASAP

Share this post


Link to post
Share on other sites

What I finally had to do to overcome this issue was to use the firefox developer tools to manually add the ID and secret (pulled from Live section of Paypal developer page). Once saved the integration was complete. 

However, I then realised that the only available method with this new module was Subscription and there was no way to disable this so I decided to switch back to previous Paypal module. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated