Jump to content

Stripe failing with "empty string" error

Recommended Posts

Tried to capture a Stripe payment and it failed with this:
"You passed an empty string for 'customer'."

While I wait for my ticket and the inevitable "upgrade (on 7.6.1) or give us full access to look" response, I was wondering if anyone knows why it's doing that and if there's a fix. I tried searching, but quoted it finds nothing, unquoted finds all instances of any word with "you" in it.
Anyone have an idea on this?

Share this post

Link to post
Share on other sites

Should anyone come across this thread after seeing this error, this fell over on mine because the client didn't have an active subscription with Stripe yet. They were subbed with the previous merchant provider we were using, and I hadn't noticed the changeover date or it might have been clearer. It would have been good had WHMCS simply said no card/profile found or something of that nature instead of heading off to the merchant without checking and the gateway log being the only hint. 
Too much to ask of a billing system, maybe. 😉

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.


Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated