Jump to content
ocastaned

Help PHP Version Compatibility

Recommended Posts

I Just ran a PHP Version Compatibility in WHMCS because I am trying to update to PHP 7.2 version, but my results shows these 4 files below below  are incompatible. Can someone help me to confirm if they are part of WHMCS? I need to know, before I delete them. I need to know  if they are part of WHMCS or they are coming from a 3rd party module.

includes/classes/WHMCS/Billing/Invoice/Item.php
includes/classes/WHMCS/Billing/Payment/Transaction.php
includes/hooks/whmcsservices.php
modules/addons/project_management/reports/graph_project_tasks.php

Thank you. 

Edited by ocastaned

Share this post


Link to post
Share on other sites

The third one down implies a third party, and looking in 7.3's files, the path includes/classes doesn't exist. 
I'd suggest you compare the file list with a stock WHMCS version downloaded from the site and see if those files are there. 

Share this post


Link to post
Share on other sites
 
 
 
 
34 minutes ago, ocastaned said:

includes/hooks/whmcsservices.php

You can download here

Share this post


Link to post
Share on other sites
6 minutes ago, wsa said:

You can download here

I just opened a support ticket in your site, to get that file, because I was not able to download it here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated