Jump to content

Recommended Posts

Good morning guys. Has anyone passed this problem in the WHMCS cron?

When you run it the following error message appears:

Fatal error: The file /home1/xxxxx/whmcsdata/crons/cron.php cannot be run by the ionCube Loader. Please ask the script provider to supply an encoded file that can run on your version of PHP, 5.2. in Unknown on line 0

The current version of PHP is 7.1.24. I asked my hosting to upgrade ionCube Loader to run on version 7.1, according to them it has been updated but the error still persists.

Can anyone help me?

 

Share this post


Link to post
Share on other sites

For sure your PHP version is 7.1.24 but Cron is running with an older version hence the error. Make sure that Cron deamon uses a recent version of PHP.

Share this post


Link to post
Share on other sites

Pretty sure the cron will use whatever the server default (on Cpanel servers) is set to. PHP 5.2 is pretty old now, and out of it's support period, so things may start to get "interesting" on that server if that's in use as the default. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated