Jump to content
hkhost

Stripe "Uncaptured" Payments

Recommended Posts

It's not shocking that it's not fixed. It can be quite difficult to fix something that you don't have a lot of information about (like why it happens, how often it happens, for who it happens etc). I've been trying to compare our cases of this bug, and I have absolutely no idea why it happens - there's no common thread - and when I finally think I have found the common thread, there's a case that disproves my theory.

What actually is shocking is that, despite this thread being very active, WHMCS hasn't dropped by to say anything for a long while.

Bugs can be difficult to fix. Giving a written update about a specific bug isn't that difficult. Instead of gathering information through multiple tickets, maybe WHMCS should use this thread (or create a new thread) to gather all the info they could. Other users could then voice their own experiences.

Edited by DennisHermannsen

Share this post


Link to post
Share on other sites
13 hours ago, DennisHermannsen said:

Bugs can be difficult to fix. Giving a written update about a specific bug isn't that difficult. Instead of gathering information through multiple tickets, maybe WHMCS should use this thread (or create a new thread) to gather all the info they could. Other users could then voice their own experiences.

Well they check everything because I give all login information I spent hrs with them and they find where is the bug 

Share this post


Link to post
Share on other sites
Just now, wsa said:

Well they check everything because I give all login information I spent hrs with them and they find where is the bug 

But that doesn't mean that they know why the bug happens. They can't just fix something if they don't know why it happens.

Share this post


Link to post
Share on other sites
12 hours ago, DennisHermannsen said:

But that doesn't mean that they know why the bug happens. They can't just fix something if they don't know why it happens.

Thank you for your very useful comments. We will continue waiting for this issue to be fixed. I guess 1 year is not enough time.

Share this post


Link to post
Share on other sites

I don't think I asked to be misunderstood, but I guess people can't see beyond the tip of their own nose... Let me rephrase in bullet points:

  • It's very annoying that this hasn't been fixed
  • This issue should have gotten more focus
  • WHMCS should have given a statement about this issue instead of handling everything through tickets

however:

  • You can't just magically fix an issue without knowing why it happens
  • I tried comparing our cases, and there's no common thread for the issue

 

Share this post


Link to post
Share on other sites

This what whmcs.com email me

After some further, in depth and detailed analysis, I have found one point of failure during the checkout.

It appears that the combination of having the TOS acceptance checkbox and the captcha, can cause the validation of the captcha to not be performed within the attempt to create the PaymentIntent over with Stripe. This happens when the user does not tick the TOS acceptance, then after it errors informing them of such, they do tick the TOS checkbox but don't complete the captcha challenge again (which has reloaded).

Essentially, an uncaptured transaction could show in Stripe, as a PaymentIntent is incorrectly created after the captcha is not completed following the failure to accept the TOS in the checkout.

I have reproduced that situation and opened up case MODULE-7478 with our development team to have this reviewed. Whilst I cannot provide an estimated time for completion for this, once we resolve cases and push features they are available at our change log, here:

Share this post


Link to post
Share on other sites

I've found something different.

We started having a lot of uncaptured payments. All the uncaptured payments appeared twice in the Stripe Dashboard.
It was not until yesterday where multiple new clients contacted us that I knew why..

Apparantly, the MaxMind Fraud module is marking random orders as fraud. The orders' fraud score is way below what we have configured the module to mark fraud orders by.

Legit orders with a fraud score of 0.1 is being marked as fraud (when they should only be marked if the fraud score is 20+). All these orders is going to Uncaptured Payments in Stripe.

Is anyone seeing the same as we do?

Share this post


Link to post
Share on other sites

I get that one time but this uncaptured payments alot time and whmcs could take a year they fix this like they did with mailchimp module take a year.

Share this post


Link to post
Share on other sites

We have found that if a order is set to fraud by maxmind - the payment is still done on Stripe-  but is showing as uncaptured.

Seems to be an issue with Maxmind module? 

Share this post


Link to post
Share on other sites
6 minutes ago, wsa said:

This what whmcs email me 

 

We have already turned off TOS acceptance checkbox and the captcha but still we get uncaptured payments .

 

for us - it looks like the maxmind module causing the issues.

Share this post


Link to post
Share on other sites

Using WHMCS V8.1.3 and would you believe it, the same error has not been resolved.

Stripe payment un-captured, the gateway log for Stripe Webhooks shows the Result as "Client Not Found". This is for a new client and new payment. Had to login to Stripe, capture the payment then manually add the transaction in WHMCS.

--------

Another issue was with a PayPal payment for a new client, not automatically marked as paid even though it went through with PayPal. Had to manually add the transaction.

The result for PayPal showed as "Subscription Created: No invoice found".

stripe.png

paypal.png

Share this post


Link to post
Share on other sites

I'm still getting this error on 8.1.3. Does anyone have a fix? I'm using stock themes and still getting this issue.

Does anyone have a work around? Incredible frustrating to have to manually capture the payment in stripe and fulfil the order manually.

Share this post


Link to post
Share on other sites

yes sometime I get also and they want more money of whmcs but they can not fix all this old bugs that peoples report a year ago 

Share this post


Link to post
Share on other sites

Add us to the list of users seeing this issue in 8.13. Just had a PO'd client get in touch with us because he "paid" us for an order that we had no record of.

Share this post


Link to post
Share on other sites
15 hours ago, D9Hosting said:

Add us to the list of users seeing this issue in 8.13. Just had a PO'd client get in touch with us because he "paid" us for an order that we had no record of.

Ouch - This is really awful! A billing software that cannot bill people! 😂 You would think staff would be all over this, Even with platitudes to make people think it's getting attention! 

Share this post


Link to post
Share on other sites

We've got one client who is managing to trigger this error every time he orders something yet it looks to be fine for everyone else. The error he is getting is related to the capatcha on the checkout page (using invisible recapatcha) so for now I've just disabled the capatcha for that page.

 

image002.png

Share this post


Link to post
Share on other sites

Yes same problem after a couple days of non-support form the WHMCS support department 😞 Has nothing to do with a custom template, nothing to do with Stripe, a guest should not be able to submit payment period. My "guests" made 8,000 + charge attempts in one week all with different emails and the Apache log matches the ip addresses and times in the Stripe log exactly

 

 

Edited by myautodj

Share this post


Link to post
Share on other sites

Hi all,

I can confirm there are no generalised issues with the Stripe module in v8.1.3 or 8.2.1.

 

On 2/26/2021 at 6:21 PM, zomex said:

Using WHMCS V8.1.3 and would you believe it, the same error has not been resolved.

Stripe payment un-captured, the gateway log for Stripe Webhooks shows the Result as "Client Not Found". This is for a new client and new payment. Had to login to Stripe, capture the payment then manually add the transaction in WHMCS.

@zomex,

I couldn't locate a ticket in your account where our team assisted with this in the past 12 months. Please do share the Ticket ID with me.

If you're currently experiencing and issue with the stock theme and order form template (twenty one and standard cart respectively), please do open a ticket so we can investigate.

 

On 4/6/2021 at 7:47 PM, yogdigital said:

I'm still getting this error on 8.1.3. Does anyone have a fix? I'm using stock themes and still getting this issue.

Does anyone have a work around? Incredible frustrating to have to manually capture the payment in stripe and fulfil the order manually.

@yogdigital,

I wasn't able to locate an account or license using the details on your Community account. If you're experiencing an issue in either version, could you please share your Ticket ID so I may follow-up?

 

On 7/22/2021 at 9:10 AM, D9Hosting said:

Add us to the list of users seeing this issue in 8.13. Just had a PO'd client get in touch with us because he "paid" us for an order that we had no record of.

@D9Hosting,

1. I see we last discussed Stripe issues about 5 months ago. If you're still experiencing the same error issues after the troubleshooting steps I provided, please do update the ticket with the information and access credentials requested, so we can investigate further.

 

2. A known cause of a "recpatcha verification failed: timeout-or-duplicate" error was resolved in v8.1.1 and above:

MODULE-7569 - Correct reCAPTCHA error with Stripe

https://docs.whmcs.com/Changelog:WHMCS_V8.1.1#Modules

We've since made further improvements to recaptcha invisible (albeit it a different error -  Please complete the captcha and try again) handling with Stripe in 8.2:

MODULE-7600 - Correct Invisible reCAPTCHA error with Stripe

https://docs.whmcs.com/Changelog:WHMCS_V8.2.0_Beta_1#Modules

Please do apply the update, and don't hesitate to create a new ticket if you're still experiencing any captcha errors with Stripe.

 

On 4/7/2021 at 1:20 PM, wsa said:

yes sometime I get also and they want more money of whmcs but they can not fix all this old bugs that peoples report a year ago 

@wsa,

The issue we discussed via ticket about 8 months ago was addressed in v8.1.0:

MODULE-7478 - Prevent Stripe PaymentIntent creation when TOS and captcha validation fail

https://docs.whmcs.com/Changelog:WHMCS_V8.1.0_RC_1#Modules

Occasional uncaptured payments are to be expected under normal operation in the event that a client's card is declined due to a Radar rule on your Stripe account.

If you're experiencing them in other circumstances, please don't hesitate to get back in touch via ticket.

 

 

On 7/30/2021 at 11:51 AM, myautodj said:

Yes same problem after a couple days of non-support form the WHMCS support department 😞 Has nothing to do with a custom template, nothing to do with Stripe, a guest should not be able to submit payment period. My "guests" made 8,000 + charge attempts in one week all with different emails and the Apache log matches the ip addresses and times in the Stripe log exactly

@myautodj,

This is a distinct issue, so have provided commentary in your thread.

Share this post


Link to post
Share on other sites

Is this still ongoing as I'm getting this in 2022 after setting up stripe as a gateway 😱

Share this post


Link to post
Share on other sites

3yrs since reported.

 

2023 now. 8.6.1 version. Still not fixed.

 

I have weekly 3-5 transaction going into uncaptured and ruining clients.

Share this post


Link to post
Share on other sites

Hi @sonuyos,

Can you please review the uncaptured pre-authorisations in your Stripe Dashboard on the Payments page, and confirm whether they were blocked by a Radar rule or a failed 3DSecure attempt?

Occasional uncaptured payments are to be expected under normal operation in the event that a client's card is declined due to a Radar rule on your Stripe account. Such pre-authorizations will automatically expire after 7 days: https://stripe.com/docs/payments/place-a-hold-on-a-payment-method

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated