Jump to content
frostfiretulsa

Stopping invoice creation temporarily

Recommended Posts

Hi,

I am in the process of manually importing customers from a non-computer source (so the process cannot be automated). 

This process is likely to take me several days or perhaps weeks to complete, due to the nature of the process (very long story and not important). There are some clients who will be somewhat past their due date (2 months or so at most), but I would very much prefer to NOT immediately generate those invoices as I enter the data in to WHMCS. Furthermore, I will not want those invoices to trigger the "past due" options, since it is not the customers fault that they are being billed late. 

I am unchecking the send emails checkboxes when I am generating the customer and products and that seems to work fine when the next due date is in the future. But what about where those dates are in the past? I am certain the system will generate those invoices and send them out... and I want to prevent that from happening until I am done with the data entry. 

Is there any way to do that?

Just to sate your curiosity, this is mostly due to the URL I have WHMCS at presently. Its temporary, and I would rather not have my customers even see it. The final URL will be installed in a few days, but I do not want to waste that time, so I would like to continue data entry. 

Any assistance greatly appreciated!


Dave

Share this post


Link to post
Share on other sites

you can prevent email being sent on Emails templates ( new invoices, reminder, a d overdue). So WHMCS will create but not sent to client, and also if you activated maintenance mode clients can not login to their client area and not see invoice. a hook can also prevent generate invoice but it is out my skills.

There is also a cron that you can deactivated.

Lime you said your clients are not database sql, you can not import it on phpmyadmin.

 

Share this post


Link to post
Share on other sites

Hi Dave,

On 08/10/2019 at 15:07, frostfiretulsa said:

This process is likely to take me several days or perhaps weeks to complete, due to the nature of the process (very long story and not important). There are some clients who will be somewhat past their due date (2 months or so at most), but I would very much prefer to NOT immediately generate those invoices as I enter the data in to WHMCS. Furthermore, I will not want those invoices to trigger the "past due" options, since it is not the customers fault that they are being billed late. 

as long as you follow the steps in the docs, you won't go far wrong...

https://docs.whmcs.com/Migration_Guide#Manual_Entry

On 08/10/2019 at 15:07, frostfiretulsa said:

I am unchecking the send emails checkboxes when I am generating the customer and products and that seems to work fine when the next due date is in the future. But what about where those dates are in the past? I am certain the system will generate those invoices and send them out... and I want to prevent that from happening until I am done with the data entry.  

if you're adding a product, I assume via the "Add New Order" method, then as long as you untick the two checkboxes (order confirm/invoice), then the client shouldn't receive any emails....

On 08/10/2019 at 15:07, frostfiretulsa said:

Is there any way to do that?

if you're not running the cron, then WHMCS won't generate invoices because of due dates - that's the safest method...

though you could manually mark these services as cancelled (just by changing the dropdown value and saving in the product tab in the client's profile, not using the Terminate button) and that should prevent WHMCS generating invoices for those services if the cron is running... but as I say, simplest solution is to not let the cron run until you're ready - and by the sounds of it, that's going to be when you reinstall at the permanent location.

Share this post


Link to post
Share on other sites
17 minutes ago, brian! said:

Hi Dave,

as long as you follow the steps in the docs, you won't go far wrong...

https://docs.whmcs.com/Migration_Guide#Manual_Entry

if you're adding a product, I assume via the "Add New Order" method, then as long as you untick the two checkboxes (order confirm/invoice), then the client shouldn't receive any emails....

if you're not running the cron, then WHMCS won't generate invoices because of due dates - that's the safest method...

though you could manually mark these services as cancelled (just by changing the dropdown value and saving in the product tab in the client's profile, not using the Terminate button) and that should prevent WHMCS generating invoices for those services if the cron is running... but as I say, simplest solution is to not let the cron run until you're ready - and by the sounds of it, that's going to be when you reinstall at the permanent location.

Ok, next probably really stupid question: How do I stop the cron? lol. 

If its there in admin somewhere, I must have zipped past without seeing. I did look! 🙂

Share this post


Link to post
Share on other sites
18 hours ago, frostfiretulsa said:

Ok, next probably really stupid question: How do I stop the cron? lol. 

the good news, I think, is that if you don't remember enabling the cron, it probably isn't running - it's setup outside of WHMCS and so if this is only a temporary install, you possibly never bothered to do it. 🙂

https://docs.whmcs.com/Crons

18 hours ago, frostfiretulsa said:

If its there in admin somewhere, I must have zipped past without seeing. I did look! 🙂

if you take a look in setup -> automation settings, there will be a red error box if your cron hasn't ran for some time... or if you check the System Health Status link from the Help tab in the admin area, it should tell you if the cron hasn't ran a while... or viewing the activity log would give you a detailed description of any cron activities occurring.

if the cron was running (with no configuration changes), then WHMCS would be generating reminders emails, invoices etc daily... if it's not doing that, and the above tell you it hasn't ran for a while, then you should have nothing to worry about.

Share this post


Link to post
Share on other sites
10 minutes ago, brian! said:

the good news, I think, is that if you don't remember enabling the cron, it probably isn't running - it's setup outside of WHMCS and so if this is only a temporary install, you possibly never bothered to do it. 🙂

https://docs.whmcs.com/Crons

if you take a look in setup -> automation settings, there will be a red error box if your cron hasn't ran for some time... or if you check the System Health Status link from the Help tab in the admin area, it should tell you if the cron hasn't ran a while... or viewing the activity log would give you a detailed description of any cron activities occurring.

if the cron was running (with no configuration changes), then WHMCS would be generating reminders emails, invoices etc daily... if it's not doing that, and the above tell you it hasn't ran for a while, then you should have nothing to worry about.

Ok ,well.. as to that. I cheated. I hired a linux/whmcs/cpanel expert from freelancer.com to set the server up and make sure everything is secured. He must have set up the cron, as it is running and it is generating the invoices lol. Oops. Now that I know its not in WHMCS I can look for it... 

As to the temporary nature of my setup, its not the server that was going to change, but the URL, which I have changed out today. So technically I should be ready to send out invoices now, but would still prefer to delay their generation until I am done with all of the data entry so I am not multitasking all this stuff when it comes time to audit the first outgoing invoices, just to make sure they are correct. The data entry process is... chaotic. The short story is that I quite literally inherited an entire web hosting business (~150 accounts containing ~360 domains), and my friends billing practices were.... well.. non existent. he somehow remembered when he was supposed to bill people, but he had no management in place at all, and his billing records are just all over the place. so its taking considerable time and effort to input each user and their domains, since I have to look up past billing history in email, paypal, bank accounts, stripe account, authorize.net account, etc and then essentially guess the next due date, etc. Its quite the job with 360+ domains to look up in this manner and its taking considerable time. Worse, some customers have multiple email addresses and so while I might enter most of a users domains all at once, I might miss one later down the list because its registered email is not the same, which is the main reason I do not want invoices going out until I am done. Just in case one sneaks in the back door when I wasn't looking 🙂

So anyway, using the other suggestion above I edited all email templates and disabled them all. But still with that job running (need to find it!) I will have to go in and edit the invoices it generates before I actually send them.  Better to turn it off now and make sure the data is correct before its first run. 

Share this post


Link to post
Share on other sites
22 hours ago, frostfiretulsa said:

The data entry process is... chaotic.

sounds a nightmare - when you've finished the data entry, ensure that you take a backup of the database so that you never have to do this again! 😰

(though if the cron is running, it might be backing up the database daily anyway - if that's been enabled).

22 hours ago, frostfiretulsa said:

But still with that job running (need to find it!)

it was probably setup in cPanel (or whichever hosting panel you're using).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated